Windows 7 sorcetree - Clone fatal Errors - Maybe git-submodule is broken?

I am really new to git and bitbucket. Installing SourceTree because I assumed it would help me figure git out. Unfortunatly I am stopped at the first stone. I run a clone off of my Bitbucket Private Repository to a local directory on my Windows 7 machine. When I run clone, select my source and destination. It gives me this fatal error:

fatal: 'submodule' appears to be a git command, but we were not
able to execute it. Maybe git-submodule is broken?

I'm sorry for this question and it is probably something simple I need to fix configuration wise but I tried searching for an answer to no avail. Any help would be appreciated.

Thanks

1 answer

Never Mind I figured it out. I had to use the embedded version of git. To do this start by going to Tools > Options > Git and clicking 'Update Embedded Git' to reinstall it. THe the button to the right click "Use Embedded Version Of GIt"

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

234 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot