Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why is "Enable GPG key signing for commit" is greyed out?

Pretty straight forward. Why is this checkbox greyed out?Screen Shot 2016-10-30 at 5.00.28 PM.png

3 answers

I had this problem after I had installed gpg through Homebrew first, and then uninstalled it to use MacGPG instead.

I solved it by going to Sourcetree > Preferences > Advanced, then for GPG Program I clicked Browse and selected /usr/local/MacGPG2/bin. After that, I was able to enable GPG signing on a repository.

Deleted user Jun 19, 2018

I was able to make it work with Homebrew. You need to create a symlink gpg2 -> gpg under `/usr/local/bin` and after that you can select `/usr/local/bin` as GPG Program path under Sourcetree -> Preferences -> Advanced

Like # people like this

Can you elaborate? I dont see any gpg2  so where did you use your symlink?

You can create the symlink pointing `gpg2` to `gpg` with the command below:

ln -s /usr/local/bin/gpg /usr/local/bin/gpg2


Once that is in place, you can set `/usr/local/bin` as the GPG Program Path under Sourcetree -> Preferences -> Advanced

You may need to press Command+Shift+Dot to show hidden files.

Turns out I had installed GPG tools, it said it had a key in the control panel thingy so I figured it was cool beans... but it turns out I didn't have a private key yet. So I clicked new, entered a password, jigged my mouse and keyboard some and it all came good.

Obvious. Yes.

I already had a private key generated, but I had to restart SourceTree for it to pick up that change. Worked fine after that.

I did. Do I have to update the GPG Program in my settings to point to GPG Tools?


Screen Shot 2016-10-31 at 2.30.56 PM.png

Possibly. Did you install the tools to a different location?

I picked the default location. Looks like it put it in my Applications dir.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,754 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you