Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why is SourceTree constantly asking me for my "User Information" during a commit?

Been using ST for months. However, as of this morning I cannot commit anything. Clicking Commit puts me in a loop of dealing with this odd dialog box. Entering any info here and clicking OK just puts me back to where I was before I clicked Commit. It's a loop I cannot get beyond, as of today. 

What's going on here?  Anyone know? 

 

SourceTreeUserInfoMsg.png

 

 

 

1 answer

1 accepted

1 vote
Answer accepted
minnsey Atlassian Team Mar 19, 2019

Hi

I'm not sure exactly why this is happening but if you go into Tools/Options/General tab you can enter the same details there and it should then update git and hg configurations when you click OK.

If you do this, potentially by explicitly editing those values to something else, clicking OK and then editing them back and clicking OK again,  does that then stop the prompt?

Thanks Michael. I tried playing with those settings a little, but it made no improvement. However, on the bright side, the ability to commit a change (no such weird message appearing) returned last week. All on its own. Weird. 

If anyone else comes across this issue, unchecking the global option worked for me

Like # people like this

I second unchecking the global option. Worked for me. 

Like Nicola Chabot likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,290 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you