It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why is SourceTree changing my files' permissions?

Whenever I perform an action in SourceTree which alters a file in my git repo (e.g. "Discard hunk"), the edited file's permissions change from 664 to 644. This is breaking my system, because other users in the files' group need write permission.

 

Why is this happening, and how do I stop it? Changing my umask value did not help. I'm using OSX Mountain Lion.

EDIT after a week with no answer:

After further research and system tweaks, I'm still seeing SourceTree treating my files' permissions incorrectly. Every single file it touches gets set to 644, regardless of my umask value. I even followed the official instructions from Apple on how to set your umask for applications, and that didn't work.

Using git from the command-line does respect my umask value, so this is very frustrating.

11 answers

another reason source tree is garbo.

how is this still a problem in 2017?

How do we get someone to look at this? I'm on Windows 10 and it is also happening to me. Back to command line I guess..

I have the same on Windows 7

dennisn I'm New Here Monday

I also have the same on Windows 7. has anyone been able to resolve?

I think SmartGit handles this better but it is not free.

dennisn I'm New Here Monday

thx.. we will try it. 

It would be better if they actually fixed this bug. Using a completely different app isn't really a solution is it?

I am having the same issue. Files and folders in the /objects dir are being created with the wrong permissions. My remote is a bare repo with the following config file: [core] repositoryformatversion = 0 filemode = true bare = true sharedRepository = true This does behavior not occur when using Git from the command line. My team is getting access errors when they pull after my push with SourceTree. This is preventing me from using Sourcetree because it is interfering with the rest of the team using command line and Eclipse. I prefer Sourcetree due to the UI. Permissions from command line and Eclipse: drwxrwsr-x 2 rossi11 hadoop 96 Feb 17 16:11 3b Permissions from Sourcetree: drwxrwx--- 2 rossi11 hadoop 51 Feb 25 11:40 3d Is there a solution for this?

Can a dev please take another look at this? My files need to have 664 permissions, and the newest SourceTree is still manually setting them to 644 every time it changes a file.

I am having a similar effect except that a file that was 755 was committed as 644. I had to run this to fix it:

git update-index --chmod=+x path/to/file

This is another plea to the developers to at least acknowledge this issue, because it's been screwing me over multiple times a day in the past few weeks.

Still no answer regarding this topic :-(?

I am also having this problem. OS X El Capitan, newest version of SourceTree.

I am also having this problem. Its driving me crazy!

This is still an issue!!!!

Was a bug report ever submitted for this?

not that i know of. I went back to doing everything in terminal, works just as fine without having to rely on other people's software

For me, SourceTree is completely unusable because of this ridiculous bug. Shame really as its a good app otherwise :( 

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted Jan 17, 2019 in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,542 views 13 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you