Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Why is Commit not working?


I select a bunch of new files to commit, then try to commit.

I get the popup saying "Checking submodules" for less then a second, then it closes, and comes back to the main UI with nothing checked in.

I can check in files to the repository by hand from the terminal, so the repository isn't the issue.

This is on Windows 10 with a repository on a Windows network share. SourceTree 3.1.2, although this has happened to me a few times on earlier versions of 3. Previously, checking in a commit by hand shook it loose...this time, no dice.

Also, I have tried it both with the "Push changed immediately" checked and not. I have tried rebooting.

1 answer

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Apr 30, 2019


Can you raise a ticket at for us to investigate? Any additional details, e.g. do you have any submodules, Git version etc would be useful

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events