Why can't I download SourceTree?

I've been trying for the last two days to download SourceTree. Each time I'm presented with a dialogue box that asks for username and password. I enter my Atlassian information and the box appears again. I want to try this out with bitbucket for a small project I'm working on. This is extremely frustrating.

4 answers

1 accepted

Not sure what's happening here.
I just verified that downloading from a non-Atlassian employee's machine also works fine, without asking for a username/password.

Can you try downloading with another browser?
Also try downloading from the direct link http://downloads.atlassian.com/software/sourcetree/SourceTree_1.5.4.dmg

If that doesn't help, you can go to https://transfer.atlassian.com
Login with username=stree154 and password=hB3dIopN.
For a limited time the download will be available there.

It worked in Safari. I tried the direct download in Chrome with the same result. Maybe the download expired on the last link, used the login information you provided and it said unable to authenticate user. But, I've got it now. Thanks! (Not sure why it's not working in Chrome though)

I've had this reported once before. What I've spotted is that in the screenshot, you're connecting to port 443, ie HTTPS instead of HTTP. downloads.atlassian.com definitely requires a login if you try to use the HTTPS address but all our links from the website, and Rene's direct link above, point to HTTP.

The only explanation is that something your end is forcing your browser to request HTTPS instead of accepting the HTTP link. Maybe you have a proxy setup or some other security set up in Chrome which is causing this?

OK. Disabling HTTPS everywhere for Atlassian did the trick. I imagine that this would cause problems in other browsers as well. Thanks again for your help!

That would explain it. I use HTTPS everywhere. I'm going to try to disable it and try again for testing purposes. I'll report back in a few.

Great, I've reported this to our sysadmin team as a potential source of confusion to see if we can prevent it in future for people who use these kinds of extensions.

Where are you trying to download SourceTree from?
I've just downloaded it from http://sourcetreeapp.com/download/.
It didn't ask for any user details, and downloaded just fine.

Just tried it. Still have the same issue. I'm using Google Chrome. Here is a screenshot.

Is there another way for me to get it? I'd like to use it tonight. I have my day job starting tomorrow.

There seems to be a problem with SourceTreeSetup-1.10.20.1.exe

I get an error each time I try, the download is looking for a file to extract that is missing

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

648 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you