Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,973
Community Members
 
Community Events
165
Community Groups

Why can't I clone the repository?

I tried to clone a repository for my Sourcetree application but I got the following error:

"
Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://*USER*@bitbucket.org/*COMPANY*/*REPO*.git
Output:
Error: remote: Bitbucket Cloud recently stopped supporting account passwords for Git authentication.
remote: See our community post for more details: https://atlassian.community/t5/x/x/ba-p/1948231
remote: App passwords are recommended for most use cases and can be created in your Personal settings:
remote: https://bitbucket.org/account/settings/app-passwords/
fatal: Authentication failed for 'https://bitbucket.org/*COMPANY*/*REPO*.git/'
"

I've tried both OAuth and Basic authentication (Sourcetree says "Authentication OK" for both versions), but I keep getting the same error.
My colleagues could clone, we can't find the cause of the error.

2 answers

1 accepted

0 votes
Answer accepted

Hi @Jacint Illes ,

welcome to the Atlassian community!

Please try to fix your issue as suggested in the following article https://itsmycode.com/solved-remote-bitbucket-cloud-recently-stopped-supporting-account-passwords-for-git-authentication/

Hope this helps,

Fabio

Thank you, this solved my problem.

I'm happy for that @Jacint Illes 

Hi @Fabil Racobaldo

I am new to Sourcetree.

 clone from bitbucket repo in sourcetree  crashed.

Whenever I want to clone a repo in the sourcetree using remote function, the sourcetree just crashed without any error. Which prevent me to clone any repo.

I tried unsinstall and reinstalled the Sourcetree ..Now My problem is I am able to clone only one repo. 
Second repo is crashing..

Appreciate your help in resolving this.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

62,179 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you