It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why am I getting "This is not a valid source path / url"

I know this question has come up, I have been reading threads for two days now, most of which pertain to remote repositories. 

I have inherited a SourceTree + Git setup from the previous support group.

  • Source code located on  inhouse Linux Server
  • SourceTree installed on inhouse Windows Server 2012
  • SourceTree: I can see two repositories (I think they are copies).
  • LinuxServer: I searched for .git folders and found 6 of them
    • 4 of them are located in base folders for 4 instances of Source Code.
    • 2 of them seem to be Clones of 2 of the above.
  • SourceTree: If I try to Clone a repository and enter the path to any of the four source instances (including the 2 that seem to have clones already), I get the error message "This is not a valid source path / url"
  • SourceTree: If I try to Clone a repository and enter the path to the "clones", it recognizes them as GIT.  
  • LinuxServer: git status from the 4 Source Code folders returned a list of "Untracked files".
  • LinuxServer: git init from 1 of the Source Code folders returned "reinitialized existing Git repository in /foldername/.git
  • Linux Server git status from same Source Code Folder returned a large list of files in Changes to be committed, as well as the list of untracked files.
  • SourceTree: tried to clone repository that I ran git init from, receive same error: "This is not a valid source path / url"

Any help would be appreciated

2 answers

1 accepted

0 votes
Answer accepted

What I ended up doing was creating the clone from the Linux Host. Navigated to desired location and ran 
'git clone /absolutepath/existing_repo'

This allowed me to add existing repo (the clone I just made) to Source Tree without the error. (I did try adding the existing repo before creating a copy, and got the error)

Had similar issue on version 2.4.8. I installed git on the machine and it worked after that. You could do this by going to Source Tree --> Tools --> Options --> Git -->Use Embedded git (If you haven't installed git on your machine) or Use System Git (If you have installed git on your machine.)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

685 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you