Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,953
Community Members
 
Community Events
176
Community Groups

When merging with FileMerge and resolving conflicts, Sourcetree leaves Conflict Markers in the file

I'm using Sourcetree v4.1.2 and I'm seeing this behavior when merging files. If I run from Terminal the `git mergetool path-to-file` command, FileMerge launches fine, I resolve conflicts and conflict markers are removed when I quit FileMerge and execution returns to Terminal.

At the beginning of this issue I thought it was Filemerge (like apple fruit, time passes and gets rotten, v 2.11 crashes when I edit a merged change), but then it occurred to me to launch mergetool from terminal and conflict markers are no longer left in the file after FileMerge quits, so clearly this is not a FileMerge issue or it's something related to how SourceTree passes ancestors and conflicted files to FileMerge.

I haven't tried merging 2 conflicted files without SourceTree but from Terminal as I described it above.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events