Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,881
Community Members
 
Community Events
176
Community Groups

Using app password returns 'Your credentials lack one or more required privilege scopes'

I received an email warning from Atlassian that user passwords won't be allowed after March 1. I followed the steps at this page to create an app password and apply it to Sourcetree (v. 3.4.7):

https://support.atlassian.com/bitbucket-cloud/docs/app-passwords/ 

I granted almost all permissions to the app password, except account/issues/wiki.

When I try to edit or add an authentication account in Sourcetree, it spins a bit and displays the error message: 'Your credentials lack one or more required privilege scopes'. I've tried both HTTPS and SSH, using Basic authentication. If I use my user password, it works fine (but of course that apparently won't work after March).

4 answers

1 accepted

0 votes
Answer accepted

I tried once again creating a new app password, and this time I gave it EVERY permission available. I used the password to create a new authentication login in Sourcetree, and this time it worked. I don't know whether adding the user-account permissions etc. actually made a difference, or if something was different with how Sourcetree connected with the Atlassian system. But it's annoying that it seems that I had to give it such broad permissions in order to get it to work.

Account Read and Repositories Read and Write are required, worked in SourceTree

I had included read/write on repositories in a prior app password, but it didn't work for me--I got the notice that it lacked privileges. That said, per my other post here, when I granted all available permissions it worked, but the extra ones I added should not have made a difference. So I'm still befuddled about why it worked with all permissions.

It works for me now with Account Read and Repositories Read and Write permissions only. Thanks!

1 vote
Pramodh M Community Leader Jan 30, 2022

@Bryan Baker 

It requires account scope!!

Thanks, but where do you set or specify account scope?

Deleted user Oct 25, 2022

Thanks, it works for me love you 

I have the same issue.

Tried both login/email as login and just generated app password, doesn't work.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events