Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Using Sourcetree with GitHub: Having Trouble Adding an SSH Key to My GitHub Account Edited

sourceTree.jpg

I'm trying to use Sourcetree (for macOS) with GitHub. The followings are the steps that I have taken many times after visiting a dozen websites include this Japanese article. I thought it's well-written. But it doesn't work for me.

1. ssh-keygen -t rsa -C xxx where xxx is my e-mail address as a comment

2. Location: /Users/yyy/.ssh/id_rsa where yyy is my user account name

3. I enter a pass phrase twice.

4. cd ~/.ssh

5. chmod 600 id_rsa

6. I edit the config file in the .ssh folder as follows.

Host github.com

HostName github.com

IdentityFile ~/.ssh/id_rsa

User git

7. ssh-add -K

8. pbcopy < ~/.ssh/id_rsa.pub

9. I go to github.com and enter the key that I copied into the clipboard under the SSH and GPG keys section of the sidebar.

10.Switching Sourcetree, I create a new account. The host is GitHub. Auth Type is OAuth. I then click on Connect Account. The protocol is set to SSH.

And Sourcetree says Upload Failed There was a problem adding your new SSH key to your GitHub account. Please add this manually via their website.  Does anybody know what I'm doing wrong? I've followed the steps with two different computers. And I can't go any further.

Lastly, I do have my private and public keys in the .ssh folder.  My macOS version is 10.15.4.  And the Sourcetree is 4.0.2 (236), which is installed on a brand-new iMac and as well as on a 7-year-old iMac.

 

Thanks.

2 answers

1 accepted

1 vote
Answer accepted

I've solved the problem for myself.  I need to select Basic as Auth Type.

1 vote
cilhao I'm New Here Jan 21, 2021

The problem has nothing to do with SSH!

The problem is that you have enabled your two factor authentication and Sourcetree is not able to connect. You must go to your GitHub account and create a Personal Access Token in Developer Settings, after that you go to you Sourcetree and edit the Auth Type of your GitHub account to Basic, fill your username and paste your newly created Access Token instead of your password, this will bypass the second factor of authentication.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

2,346 views 4 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you