Unable to Pull, Fetch, or Clone repos

Since last week I've been unable to pull the most recent changes from my repository. I don't get any errors and the output sticks on the first command it shows:

"git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive https://git.example.com/server/etc"

I've run fiddler and don't see any output from SourceTree, and I've also tried reinstalling the program multiple times, in addition to this I've deleted all my existing local repositories and tried to recreate them, only to have the clone command hang. I'm all out of ideas of what to do here so any help would be appreciated.

1 answer

there may be something screwy with the command that SourceTree is trying to execute through the GUI. After reinstalling everything again I went through the command line to see if I could get it to work and was able to successfully pull in a copy of my repo.

I don't know what might have caused this but it seems to work through the terminal where it won't through the GUI.

I have an almost similar problem. Tried all you mentioned above, no progress. It throws a STATUS_ACCESS_VIOLATION exception. Any idea how i can solve this one because my Pull does not succeed

I couldn't tell you. I'm still learning and don't really have enough experience to help other people troubleshoot. I only got my issue fixed, not really figured out.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

573 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you