It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

UI not sync after every operation Edited

Hello,

on some PC of our team sourcetree don't sync the UI after every operation.

For example, if I change branch, it make the checkout then the UI still on the old branch, but if I refresh the UI (with F5) the change are reflected and the current branch is the branch that i have checked out.

It have the same behavior also on changes on staged file, after commit, after pull, push etc. etc.

So they need to continuously press F5 after every operation to get the UI synced and this is so annoying!

All PC that had this problem had a nVidia Quadro family graphic card, it's the only thing in common between this PCs that we found.

We use the last Sourcetree version available and embedded git updated to the latest version.

Please help to solve this issue, we don't want to change software.

3 answers

Seems that close all tabs and reopen the repos fix the problem like suggested by an user on another thread!

Glad you found a solution!

I also tried but I can't even close the tabs - clicking 'x' on the tab, right-clicking "close tab", or "close all tabs" does absolutely nothing.

I guess I will have to create a new ticket.

if you have only 1 tab you need to open a new tab with + before closing the old one. Having 0 tabs seems a not allowed state.

Some members of my team report that the workaround work for like 1 hour then the bug come back :-(

Unfortunately I can't test myself because on my PC don't have this bug...

Like glenneroo likes this

Thanks, good tip, that seems to have fixed the issue as well! Now I just have to wait and see if it comes back after an hour...

Still a problem even with this workaround, as I have to repeat this process every time I open Sourcetree.

Like Emilio Garcia likes this

I've downgraded to 3.3.4 until they can release a fix (https://www.sourcetreeapp.com/download-archives)

+10 point to have found a link to the old version :)

Are you guys on Mac? I only see ZIP files with MacOS versions on that link...

Scroll down or search 3.3.4 in the page, it's here :)

My bad, I accidentally scrolled past the Windows versions and ended up at Enterprise for Windows. Thanks! ;)

Like Simone Gallerini likes this

I'm encountering the same issue in the latest Windows version 3.3.6, having to manually F5 after every operation.

Likewise. I've been using 3.2.x for the last 2 years and after updating to 3.3.6 last night, I have to F5 (or restart SourceTree) to refresh.

I would roll back to an older version but I can't find the Windows installers for previous versions - the download archives only seem to contain zip files with MacOS versions...

Do you have quadro graphics card on that PCs? In our team trhe issue seems related to that card because all PCs that have other card works great...

No Quadro, it's a 2080 Ti.

Intel UHD Graphics 630 and NVIDIA Quadro P1000 laptop here.
Same problem with the v3.3.6 release.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

2,763 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you