It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

This is not a valid source path on source tree

tyrone allen Jun 15, 2013

I have created my first repository on bitbucket and newly downloaded git and sourcetree. when I attempt to clone the repository and source tree asks me to enter the source path, I am given the message "This is not a valid source path" and the details are :

warning: bitbucket.org certificate with fingerprint 24:9c:45:8b:9c:aa:ba:55:4e:01:6d:58:ff:e4:28:7d:2a:14:ae:3b not verified (check hostfingerprints or web.cacerts config setting)

abort: HTTP Error 404: Not Found

error: Failed to connect to 92.242.132.15: Can't assign requested address while accessing https://tallen92@bitbucket.org/tallen92/physical-modelling-synth.git/info/refs

fatal: HTTP request failed

Any suggestions on what is wrong ?

thank you

9 answers

3 votes
Khairy Abd El-Zaher Sep 29, 2013

u can enable Git from source tree options. it fixed it for me.

0 votes
Steve Streeting Jun 16, 2013

Hmm, that sounds like it might have been a transient error on the Bitbucket side, or some other networking issue. I just tried with a few other Bitbucket repo addresses here and all seems well, can you try again?

tyrone allen Jun 21, 2013

Hi thanks for the response. I tried again and the same error message appeared.

Steve Streeting Jun 23, 2013

Are you sure you have the right URL? I can't see that project presumably because it's private, but please double-check the URL is correct because that's the only reason you'd get a 404 barring some intermittent issue.

If it definitely looks right according to the clone details on Bitbucket then maybe this is a Bitbucket issue, although I've never seen it happen before.

tyrone allen Jun 23, 2013

The path is correct but its stills does not accept it. Should I create a new account ?

Steve Streeting Jun 24, 2013

I wouldn't go that far - are you able to give me permission to try it myself, or if not can you create another repo with a similar name that is public to test with?

tyrone allen Jun 25, 2013
I have given you access to the repository.
Steve Streeting Jun 25, 2013

Thanks, I can see the repo just fine:

I'm thinking authentication now, but a) SourceTree should prompt you if there's an authentication error, and b) you wouldn't get a 404. Just to be sure can you go into Tools > Options > Authentication and delete your saved password for Bitbucket? You should get re-prompted then just to be sure.

tyrone allen Jun 25, 2013

This is very trivial but I cant locate the tools menu in sourcetree.

Steve Streeting Jun 25, 2013

Ah, sorry I thought you were on Windows, on Mac it's Preferences (Cmd-,) and it's in the Network tab. FYI I just tested the URL on my Mac too and it resolved fine there too.

tyrone allen Jun 25, 2013

I went to the networks tab and the contents of the table is empty.

Steve Streeting Jun 26, 2013

Hmm, that suggests it's never prompted you to log in, so never saved your login details. Looking at the repository now, it's public so actually you wouldn't be asked to log in anyway so that makes sense, and from the error you were getting before (404) I guess it makes sense that it never got to the login prompt. So I guess we can rule out authentication. I just deleted my saved password for Bitbucket here and tried cloning your repo again, and it cloned just fine with no password prompt as expected because it's now public.

So I'm at a loss why you're getting a 404 when you try to clone. You're *definitely* using this URL, right?

https://tallen92@bitbucket.org/tallen92/physical-modelling-synth.git

If so, do you have anything locally which might be intercepting your HTTPS requests, like a proxy setup or some other web relay which could be triggering some intermediate error?

tyrone allen Jun 26, 2013

A few months back, at university when I first tried to setup a repository, I was told to enter this command :

git config --global http.proxy proxysg.uwe.ac.uk:8080

In order for Git to work in the university proxy.

Steve Streeting Jun 26, 2013

I can only assume this proxy is blocking git's access to bitbucket.org, because everything works fine with your repo from here. This setting will be stored in your %USERHOME%\.gitconfig, you can comment it out with '#' and try on a different network to see if that's the case.

tyrone allen Jun 27, 2013

I removed the proxy settings so the file looks like this.

[user]

name = Tyrone Allen

email = tyrone2.allen@live.uwe.ac.uk

[http]

[core]

excludesfile = /Users/tyroneallen/.gitignore_global

[difftool "sourcetree"]

cmd = opendiff \"$LOCAL\" \"$REMOTE\"

path =

[mergetool "sourcetree"]

cmd = /Applications/SourceTree.app/Contents/Resources/opendiff-w.sh \"$LOCAL\" \"$REMOTE\" -ancestor \"$BASE\" -merge \"$MERGED\"

trustExitCode = true

But it still does not work.
tyrone allen Jun 27, 2013

Just realised I edited the wrong file. Tried it again and its works ! Thank you for your time and patience. Much appreciated.

Steve Streeting Jun 27, 2013

\o/

Great to hear you got it working, welcome to Bitbucket / SourceTree :)

0 votes
yhiea elgamal Aug 28, 2013

i have the same error, what can i do to solve this problem?

tyrone allen Aug 28, 2013

My problem was that I had a http proxy setting stored in the gitconfig file, once I removed the setting, sourcetree worked fine.

yhiea elgamal Aug 28, 2013

in windows 7.

yhiea elgamal Aug 28, 2013

thanks for replay,

where is this file in windows 7 ?

0 votes
yhiea elgamal Aug 28, 2013

thanks for replay,

where is this file in windows 7 ?

0 votes
yhiea elgamal Aug 28, 2013

thanks for replay,

where is this file in windows 7 ?

0 votes
Brayden Jo Oct 13, 2013

I have a same problem

git clone https://hyunhojo@bitbucket.org/hyunhojo/testrep.git

I can't clone the repository (testrep)

I checked .gitconfig file however I cannot find the http proxy setting.

What is the problem ?

Answser

I am not sure whether the soulution is right or not.

I see the "Protocol https not supported or disabled in libcurl".

I copied the "libcurl.dll" file from "C:\Users\KKK\AppData\Local\Atlassian\SourceTree\git_local\bin\" to "c:\Windows\SysWOW64\"

After copying the file, the clone works well again.

0 votes
Andrew Piechocki Jan 16, 2014

I have the same problem as the OP. I can not figure out how to get it working.

https://apiechocki@bitbucket.org/apiechocki/digisparkarduinointegration.git

any advice would be helpful!

0 votes
Isuru Walpola Oct 24, 2015

Sorry for the late answer guys.

Step 1: Make sure you've installed Git from http://git-scm.com

Step 2: Set git proxy.

In Git bash, type 

git config --global http.proxy http://proxyuser:proxypwd@proxy.server.com:8080
git config --global https.proxy https://proxyuser:proxypwd@proxy.server.com:8080

Step 3: Set SourceTree to use Git

Now, in SourceTree, go to Tools>Options, then in the "Git" tab, enable git support by doing whatever necessary.

Step 4: Connect Bitbucket account, and use HTTPS, not SSH

Now, it should work just fine.

 
0 votes
Scott Taylor Mar 20, 2019

Deleting all my remote accounts in SourceTree, then reconnecting to my Bitbucket Server, and re-entering my credentials, allowed me to successfully clone my repo.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

465 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you