Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,680
Community Members
 
Community Events
168
Community Groups

The team is getting an error stating "Unable to read membership from the remote host

Edited

The team is getting an error stating "Unable to read membership from the remote host. This endpoint has been removed". The team was able to connect before but now there seems to be a problem in doing so.

This issue happening when trying to connect Bit bucket from source tree. While checking the authentication, it is working fine. 

can anyone look into this issue from sourcetree team and answer how to resolve this issue

 

14 answers

We have followed the below steps to resolve this issue

1. Upgraded source tree to version 3.4.7 (May be 2 or 3 times you have to update to reach the version 3.4.7)

2. deleted the existing account from the source tree - Tools - Options - Authentication. 

3. added again with Authentication mode - OAuth - and click on Refresh OAuth Token. It may ask for the login credentials. 

4. Still if you are getting error in the source tree in the remote tab - please click on refresh button just below the search bar. 

This mostly works, although I cannot refresh more than one OAuth accounts.  When I click the "Refresh OAuth Token" on a second account, I get the "An Account already exists for 'First account Username' " message and in the grayed out Username textbox it has change to the first account.  Only affects BitBucket accounts as far as I can tell.

I've been seeing the same error.  The error also shows, "The endpoint has been removed."  I remember seeing an Atlassian email recently that they were deprecating some of the BitBucket API endpoints.

Wonder if they forgot to update the SourceTree endpoint calls.

Apparently the SourceTree auto-updater broke at some point.  My version was stuck at 3.3 but showed up-to-date.  Manually installed the latest, 3.4.7, and everything works again.

Like amoreno-kiterocket likes this

Used auto update to 3.4.7 which completed successfully but version number didn't update in control panel -> programs. Manually updated to latest version but it was still showing this error even after refreshing OAuth token. Clicked refresh on the remote repo list and the error disappeared.

Like # people like this

I found a work around at least in our case, which seems to be limited to Citrix workspace running Windows 10.

Refresh the OAUTH token.  Edit my Account from within SourceTree and selected Refresh OAUTH Token.  I was able to clone new repos and update existing ones.

Hope this helps until we get a permeant fix from BB.

Tried this option. still the issue persists

Same problem, I've tried all the fixes and none of them work after a few hours of time wasting decided to move over to Github Desktop

did anyone get any solution to this issue?

I downloaded full version of SourceTreeSetup-3.4.7.exe and installed it.  I also had already completed the reauthorization of token on options page.

That fixed my problem.  The app was not auto updating fully so running the full install file seemed to help.

Ok I got it working today.

 

- Manually updated to 3.4.7. Just with that still didn't work.

- Clicked edit account and removed all.

- Added account again with basic authentication. Still showed the red X.

- Tried to search something and magically worked.

 

I could clone one of my remote repositories just fine.

same error, any fix around it?

My users are still experiencing this issue. Product is up to date.

Same here. I can sync repositories I already have in my local but when I try to look for remote repositories to clone something different I get this message.

Same issue here. Any updates? It has been a week. 

Same

I am having the same issues this morning

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events