Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

The server's host key is not cached in the registry

Hello everybody,

I'm trying to fetch the commits list from the server via the GUI. After the click on a Fetch button, I get the "Fetching All" progress bar, which seems to work, but not too efficient.

Full output says I'm supposed to add the key fingerprint to cache; to do that, I need to type "y" to console window. But for obvious reasons, I cannot enter "y" into console window, since there is no console. 

Here's the screenshot:


Installed SourceTree version:

Thanks for the help in advance!


5 answers

1 accepted

3 votes
Answer accepted

Hi Richard,

Solution here

The workaround is simple: just get SourceTree to use Embedded Git and get it to trust the host:

And then change it back to System Git.

This should resolve the issue.

Best regards, Damien.

For some reason it doesn't help; I cannot see this window during the "Fetch" procedure. The situation is the same. 

Hmm... And, with this:

This is a known issue with SourceTree, refering to, here is the solution:


  • Open Command Prompt
  • "C:\Program Files (x86)\Atlassian\SourceTree\tools\putty\plink.exe"


  • Fresh install of Windows 10 Pro 64bit
  • SourceTree
  • Embedded git

I hope it will resolve your issue Richard! smile

Seth Rising Star May 25, 2016

You can also just launch SourceTree's Terminal, and run "ssh <hostname>".

You don't need to actually have the ability to connect via SSH - the ssh software will check the key first, so you can accept it before the server decides whether you're allowed to connect.

Latest Damien Braz solution with running plink.exe worked for me.
I used plink.exe in my installed version of SourceTree folder and instead of "" I connected to my problematic server and was able to finally allow it.
After that all worked smoothly.

For me, the trick was to switch from putty to open ssh in the general options.

Hero! This fixed it for us after hours of frustration! 

Like Claudiu Hangea likes this

Worked for me too!

Worked for me. Plink wasn't even installed (or could not be found).

This worked for me. Thank you for posting the answer.

Thanks, this worked for me too, running version 3.1.3 on Windows 10.

Nice, thanks!

Worked for me too!!! Thanks!!!!!

Worked for me, SourceTree 3.3.8 on windows

I am also stuck as Jeffery Brewster is.   

Trying the command line (with a different, correct, path to plink) asks me to "login as:" after which it tells me that there are no supported authentication methods.(FATAL).


Not sure what to do.

Not solved. None of this works.  
Trying embedded git, gets me the same result. (No prompt). (makes me question the integrity of this software; why would it work differently on different systems of the SAME OS?? :: (   ))

Trying the command line (with a different, correct, path to plink) asks me to "login as:" after which it tells me that there are no supported authentication methods.(FATAL).

Glad it is so painful to get this working on a brand-new, clean Win10 install....(great product! <-sarcasm intended)

I did this (with embedded Git on) and it solved it for me:

1. copy the Git command from the message
2. Actions --> Open in Terminal
3. insert the Git command
4. the original message appears in the terminal and you can answer it

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events