Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Stop tracking marks file for deletion

I want to stop tracking a file so I can then ignore it. When I do stop tracking, it puts it in my index with a RED circle for deletion.. reading online it seems it should be putting a question mark instead, I'm afraid it'll delete the file.

What am I doing wrong?

4 answers

I'm not sure exactly what you are looking for, but what you describe will delete the file from the repository, but not from your working copy. In other words, the file will still be in the directory you are modifying, but if someone was to clone your repository, they wouldn't have the file at all.

I don't know of any way to ignore a file in your working copy that exists in the repository.

Well, isn't that what gitignore command is(Which worked in the command line)

It allows me to ignore the changes I make locally, but keep the file in the repo. For example I'm using this to hard code my ID and PW in a form, but obviously I don't want to check it in to git.. So this way this login file is ignored...

I was able to do it in the command line, just curious why it's not working with sourcetree.

It's just a matter of misunderstanding the command. For some reason Atlassian appears to have made the decision to disable ignoring tracked files via the UI. "Stop tracking" is a different, but still important, feature.

I expect ignoring files like this is a rare occurance. You'll just have to rely on the command line, I think.

Sorry to necro an old thread but the SourceTree behavior seems a little inconsistent (there's probably a reason, but I don't know why). For one file I clicked "Stop Tracking" and it turned to a question mark, then I clicked "Ignore." Worked fine, submitted .gitignore.

Next two files, I clicked "Stop Tracking" and they turned into red Xs. I committed those, THEN the same files appeared with question marks... then I could ignore them. Checked .gitignore, looked correct, submitted.

I don't know why the behavior was different, but... it seems sometimes you can "Stop Tracking, Ignore" other times you have to "Stop Tracking, Commit, Ignore."

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,265 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you