It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Souretree registration problem ...

Hello,

Registration step failed with Authentication Success. The "Next" (Suivant) button is always disabled. Does someone has already solved this issue ?

Thanks for help.

Fred

 

capture-006.PNG

capture-007.PNG

capture-008.PNG

14 answers

1 accepted

1 vote
Answer accepted
Ana Retamal Atlassian Team Jan 18, 2019

Hi Fred, welcome to the Community!

Can you close and re-start Sourcetree? If you're still having issues and are unable to proceed, could you answer the following:

  1. Which option have you chosen there? Bitbucket Server or Bitbucket Cloud?
  2. Which version of Sourcetree are you using?
  3. What browser are you using? Can you make sure that Internet Explorer is updated to the latest version? (Sourcetree relies on it for authentication).

Let us know!

Ana

Hi Ana,

Thanks for your help. I think it is linked to my IE web browser configuration.

I will let you know the end of the story.

Fred

Why is this an accepted answer?

I have exactly this issue, right now, on a brand new Win10 machine. I'm trying to migrate to it, installing latest sourcetree, and have exactly the same issue as detailed above, but my IE won't open the localhost page, so SourceTree won't register.

Like # people like this

I've now reached the same stage (there were local permissions issues in IE trusted sites - the atlassian site wasn't allowed to redirect) - I have this page - 

Authentication Successful

S

But still no registration on SourceTree.

Like # people like this

Hi @Ana Retamal , @monclaf 

I am facing the same problem that @zaxxon_123  has mentioned

Could you please help?

 

Thanks,

Logesh

We are getting the same issue here.

I have tried Chrome, IE and Edge. Getting the Authentication Successful message but the Next button is disabled.

We are logging on to Bitbucket (Cloud, not server).

Also tried running the application from C:\, copy/pasting the URL into a different browser - nothing seems to work. Can someone from Atlassian please respond and open a ticket for investigation?

Like # people like this

Hi Steve,

By configuring your access to your Bitbucket cloud via IE should solve your problem.
To do that you may configure proxies and/or certificates, depending on where you are located to access to your Bitbucket Cloud.

Even if for my case I was using our intranet Bitbucket server, it seems to be the same configuration to do on IE to connect via cloud.

Fred

Like Maxim voitenko likes this

Same issue here on Win 7. We tried Chrome, IE, and FF. After "Authentication Successful", none of it seems to actually confirm back to the installer.

I have exactly the same problem (Win 7, SourceTreeSetup-3.3.6.exe, both Chrome/IE).

Any idea?

Same problem since SourceTree 3.3.8. Corporate Chrome browser with corporate firewall rules. No way to use an external unprotected internet access on my PC.

So what's the solution ? Buy gitkraken ?

Fork is free.  And while it's not as good as SourceTree it will work well until you get SourceTree working!

Like Anoril likes this

@Arnaud_LINZ Or check out the solution I posted below. It worked for me and some others, so it might work for you as well.

I've tried your solution Markus, with no success.

I've tried Fork, and it's actually far faster than SourceTree and fits well for the day-to-day tasks.

I'll go with fork for now.

Thanks for Fork, it seems to be as usful as SourceTree!

Like Anoril likes this

It's over a year since this topic was created and the issue with the installer still exists. I'm unable to install SourceTree on a completely fresh (and fully updated) install of Windows 7, having tried both Firefox and IE for the authentication process (both of which claim it was successful without letting me progress). It's amazing that such a critical flaw can survive unfixed for so long.

Thanks for the Fork suggestion, it looks like I'll be moving to that instead.

Same here, fresh Win7 and no way to to register

This is not an answer! How can be "this" accepted answer??

I had the same issue, using a company network, with the newest Version (3.3.6), but I found a workaround, which worked for me and hopefully for you as well.

  • Download the installer for version 2.6.10.0 from the Download Archive
  • This Version uses a build in account login screen and doesn't use a browser, which prevents the "authentication successful" error to happen at all.
  • Now you can download the newest version and install it without needing to register again. Or just stick with v 2.6.10 which I prefer, since the newer versions are super laggy somehow (Just switched back to 2.6.10 on two devices today).

Hi, I had the same problem

previous version (one ealier) worked.

Thanx

Like Anoril likes this

Hi,

I followed this way (as previous version has the same bug). Unfortunately, after updating to the newest version, registration window pops up again and won't work again just like with the newest installer. Tried all kinds of browsers, security settings, different networks..nothing works. Looks like I must move to another client then.

Any advice is appreciated. Thanks.

Thanks Markus, switching to the older version worked for me. I haven't upgraded though so I can't comment on if the registration stays.

version 2.6.10.0 work!! 

thanks.

 

and It could be updated to 3.1.2, but if I update to 3.3.8, the same issue happen.

Thanks! Had the same issue with 3.3.8 but version 2.6.10 works!

I was able to install 2.6.10 then the update took me to 3.1.2 but then the next update to 3.3.8 would not activate the Next button.

Previously I had a firewall issue with the localhost key but then I fixed that to get a registration success response but still no Next button. Now the localhost link is giving a blank page so I'll be sitting at 3.1.2 until the installer issues can be fixed in perhaps a newer release.

FYI, I'm doing this on a Windows 7, National Instruments test system. I've not had any problems so far with any Windows 10 desktops.

Thanks bro. :)

Same here.

3.3.8 doesn't want to install
2.6.1 doesn't want to log in.

Is this a native soft for bitb right?

Same issue for one of our developers here.

Latest version of SourceTree.  Bitbucket option.  Using Internet Explorer - within a corporate network.  They got the "Authentication Successful" page, but Sourcetree never updated to allow the Next button to be clicked.

This is my issue now, attempted this at 3.1.3 3.3.4 and 3.3.6 None of them worked.

Hi @Ana Retamal ,

I am facing the same issue.

The browser version is IE 11.0.9600. Received authentication success message, but the button is disabled. Could you please help?

Thanks.

Hi Ana,

I have changed the way to connect, I've choosed "Server Bitbucket" instaead of "Bitbucket" and have selected my personal bitbucket url. At the same time, I've used IE to log in to my server also and to answer to "captcha request".

I hope, this may help you.

kind regards,

Fred

Hi @monclaf ,

Thanks for your suggestions. I have tried the steps and it asked me to enter bitbucket user credentials.

Since my organisation has enabled single sign-on, I have tried both windows password as well as Bitbucket password. but nothing worked. The error "failed to check login for user <username>" throws.

@Ana Retamal  - Could you please help on this one?

 

Regards,

Logesh

I had been dealing with this issue all morning, finally fixed it. There are 3 things I've done and honestly not sure that they are all the fix to the problem, so try the easiest one first and see if it works for you.

From easiest to more complex: (in Windows)

Easiest

1) I realized I had downloaded the Sourcetree Enterprise version and it's an .msi file. So make sure you are getting the .exe file instead from here https://sourcetreeapp.com/?v=win

SourceTree.PNG

2) Sometimes, depending on your admin privileges, running the .exe file from the "Dowloands" directory could create some certificate issues. Save the file in the "C://" drive and run it from there

3) when you are prompted to the installation window  (with the "Install", "Registration, etc list on the left), click on "Bitbucket", which will prompt the URL page to authenticate. DO NOT "grant access" yet. Copy the URL link

4) paste it in another browser (I used Explorer), grant access, there... Things may work then! 

If the above steps did not work....

Medium

1) Locate the Sourcetree shortcut icon, right click and select "properties", then "Compatibility", select the right OS. In my case I selected Windows 7

2) Also, make sure the "Run program as administrator" is selected

3) reboot computer, rerun program, repeat steps from the "Easiest" part

 

If the above didn't work...

Hardest

1) Open up the command line.

2) type: net time \\<your computer name>.<org domain>.<com/org/net> /set /y

Example:     net time \\carlacox123.sourcetreecorp.com /set /y (then hit enter)

My thought was that maybe the OAuth request was still waiting for whatever reason, so the .exe program interpreted the "hand shake" process that never done... so I set my computer time to run locally rather than at Web Server time UTF.

3) I repeated "Easiest" step again, everything worked.

Good luck!

We were able to proceed by running the install fresh from an external (outside corporate network) connection. IE / browser security is perhaps causing the issue.

@Markusthank you so soooo sooo sooo much :)

Like Steve Macleod likes this

Hi,

 

I have the exact same problem.

I want to install Sourcetree 3.1.2 with my Bitbucket account. But when I grant the access on firefox, nothing append in sourcetree. The "suivant" button is still disabled.

I try whith IE and edge and i'ts the same problem.

Alexis

Hi,

It was not working with Firefox, so I try with Chrome and it worked for me.

Fred

Like Maxim voitenko likes this

Tengo el mismo problema en win7.  Sourcetree 3.3.6

If anyone is interested in alternatives - I can recommend GitExtensions, which has the added bonus of being open-source itself (I've already made a small modification to help it work more seamlessly in the Gerrit environment we use here).

I eventually gave up trying to get SourceTree working.

After many problems being prompted.... I gotta say, the REAL solution: screw GUI interface, go straight to Git BASH. The learning curve could be a bit more tedious, but in the end, you'll need to know Git, not SourceTree

Why this is solved? Same issue on v.3.3.8.

I think all unresolved issues become "solved" after they have been sitting for one year... it's an autonomous process that someone thought could be a smart business tactic

Like zavla likes this

Make sure you run the installer as an administrator, this solve the problem for me. 

Didn't work for me.

I have same problem with sourcetree versions from 3.X.X for up. My problem has solved with following @Carla_Cox (Thanks Carla for your help :) ) instructions. But the last version not work appliying same steps. For the last version work this following steps.

1- Run sourcetree installer 

2- Disable proxy on my sistem (IE/Edge Options)

3- click on bitbucket option and install successful.

We use MFA, this helped me get around it...
https://www.codetd.com/en/article/9036212

 

windows with 3.3.8

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,999 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you