Sourcetree without external repository

Hi,

Is there a version of Sourcetree that allows sharing code among a developer group but doesn't require storing code in an external repository such as GitHub?

TIA,

Alex

1 answer

1 accepted

Hey there,

SourceTree has no limitations like this, all it wants is a URL to the repository. Git is a distributed system - the repository can be stored anywhere. If you want repositories behind the firewall and have an interface to that you could consider using Stash or Gitolite.

In short the answer is yes - you could get something up and running for people to share code in a repository on your local network within mere minutes.

Cheers

Thank you very much Kieran. I have another question but will ask it on a separate thread.

Hi Kieran,

You mention that you can use sourcetree and gitolite but I cannot get this configuration to work. Source tree does not seem to recognise the gitolite server. I keep getting the error that indicates that it does not recognise my url as a path to a git server. If I bypass gitolite and I point straight to the repositories folder then it works. What could I be going wrong?

Try to connect to the gitolite server with the command line git client to see if you get a more specific error message. Off the top of my head, SourceTree may choke if you are using HTTPS with a self-signed certificate.

I tried that and I get a similar response:

fatal: '/testing' does not appear to be a git repository
fatal: Could not read from remote repository.

I am not using HTTPS. Should I be?

I have installed git and gitolite and am simply trying to clone one of the repositories that are created by the default gitolite setup. If I do this from the server it works. As soon as I try to use the same command from a remote windows machine I get the above error.

If I bypass gitolite and I go straight to the repositories folder it works but then that defeats the whole point of having gitolite.

If command line Git is giving you the same response, then the problem is either with how you have gitolite setup, or how you're trying to access. You'll probably have more luck if you pose your questionin a gitolite forum of some sort. Try to git it working via command line first, then if SourceTree still has issues, come back here.

Thanks Seth. That saved me from annoying a lot of people. :-)My gitolite config was incorrect. I have now managed to get that working with the source tree command line.

The GUI still gives me the same error. Is there some trick to getting the GUI to identify the gitolite server?

Aah... fixed that one too.

The problem was that Pageant was still using the old key. I just deleted that and manually inserted the correct one.

I think this is a bug because in the GUI I had already changed that key to my one. It does not seem to refresh the one being used by Pageant.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

241 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot