It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree setup - unable to login to Bitbucket server

I have just installed Sourcetree, going through initial setup, and I cannot login to my Bitbucket server. 

For ROOT URL I am using https://bitbucket.org/DU3O/

For username I am using DU3O

The error I am getting is: Failed to check login for user [DU3O]: the URL 'https://bitbucket.org/DU3O/rest/api/1.0/users/DU3O' returned code 'NotFound'

I have tried using my email address as my username, but in that case I get the error: Invalid URI: The hostname could not be parsed

Thanks in advance for any help in resolving this.

11 answers

1 accepted

17 votes
Answer accepted

It may be important to know that BitBucket Server is a product line from Atlassian, and is different than the Cloud based BitBucket.org. It's quite possible this is why you're experiencing an error. BitBucket Server is installed inside a corporation and the domain is typically one designed by the corporation itself such as https://devops.acme.co/bitbucket.

I hope this helps.

Oh my gosh.  How FRUSTRATING!  Andrew, I so appreciate your post.  That is exactly the problem.  I logged into my Atlassian account and I'm now on my way.

Thank you so much for your assistance.

 

Best!

Like azubiwelt.zapp likes this

Thank you so much Andrew !

Really frustrated and finally your solution helped me. Thank you so much Andrew.

The example link is broken anyway...

We have a Crowd, JIRA, Confluence and BitBucket server installed on our own domain and use base url set in BB settings to login in SourceTree although it's not working even though confirmed my username and password work by successfully logging into the instance. I use Sourcetree locally for my repos and don't even need to log into remote instances so why has this app become completely useless without authentication?

Can anyone walk me through the steps to install and use Sourcetree version 3.0.12 . I am able to login with same credentials in the browser but getting Failed to login error in sourcetree. It's just now messing with my head.

Anyone figure out how to install Sourcetree using Bitbucket Server root URL??

Can't login via CORRECT credentials to Bitbucker Server.  So try creating (another) new Bitbucket.org account.  Get this message:

We're opening the Bitbucket Cloud signup page in your browser. Come back when you're done to continue setting up Sourcetree.

Guess what, nothing happens when you come back.

The company dictates that the repository is hosted on Bitbucket. And I have happily used SourceTree for many years. And I'm happily connected to the repository via the web portal. But if I can't get through the installation to use the GUI, I guess I have to use another company's GUI. So sad.  Does support actually read these comments. Fix it...

I believe you’re experiencing the same issues as others. That login page is only for the Cloud BitBucket.org servers not for BitBucket Server. You can use the UI with your BitBucket server if you treat it like any other git repo.

Their Login page doesn’t work with on premise servers. Just clone your repos like you would anything else in the UI by using the ssh url.

Thank you for the reply. I definitely have an on-premise server. And I have no issues cloning and using the repository via command line or other VCS GUIs. But I must be missing something as it still seems that I am out of luck if I want to use any current version of SourceTree because I can't get past this step of installation/registration.

Why not just allow simply installation and ask to login then?

I hate this install, I cannot login via Atlassian while installing the tool, while via browser I can. It's driving me mad.

Like # people like this

me too. It's like they don't want you to use it

Like # people like this

Still doesn't work. What a shame to release such a crap.

Like # people like this

I give up sourcetree for other products more friendly and easy to use.

Despite being a former user of sourtree, i loved it before this last version.

So bye bye Sourcetree

Like # people like this

like Source Tree a lot as a tool, and use it pretty much everyday, but to be honest the latest installation process through bitbucket.org is a pain in bottom part. I got my PC reinstalled and stumble upon this crap (do not have other words to describe the installation process of Source Tree now) - somehow i got through it OK, by creating & opening account first in a browser and doing all that magical stuff others mentioned above, wasting about 30+ min, Seriously, if i'd be a new user i would choose not to do that and would go with other tool....

I would recommend SourceTree team to reconsider their installation approach.

1 vote
Deleted user May 28, 2018

Just try simple login put your bitbucket username and bitbucket password

select hosting service : bitbucket

dont change next two options leave it as it is

then authentication is basic 

username is your bitbucket username 

password is your bitbucket password

SourceTree version 3.0.1 and still no joy to log into my BB Server instance :(

What a nonsense coming out from Atlassian in the past few years... you're really letting your customers down on many fronts at the same time and gradually forcing us to switch to other alternative tools... you don't even listen to us anymore hence tickets that haven't been actioned for 5+ years!

Screen Shot 2018-12-03 at 12.16.57.pngScreen Shot 2018-12-03 at 12.17.29.png

The registration / activation worked for my Cloud Bitbucket in this version of SourceTree in case anyone's using it. Still, it should work with my BB Server without the need to log into Cloud.

You don’t need to log into the Cloud version for your local BB to work. I don’t use it at my workplace and it connects to the BB On-Premise just fine. The big difference is that SourceTree won’t know it’s an On-Premise instance it just knows it’s a Git Repo. So use the normal means to connect to your local BB and you’ll be fine.

The issue is that the tool doesn’t make it obvious what’s happening. Once you realize that the tool doesn’t understand On-Premise Installs of BitBucket itself, it’ll make sense. Because On-Premise BB uses SSH and HTTPS protocols it can connect. It just doesn’t know what type of Git server it is. 

 

in short: connecting to the cloud isn’t needed and has nothing to do with connecting to your local server.

Hi Andrew,

It used to be like that until Atlassian introduced forced sign in. The app is presenting only a sign in screen with no other options and virtually unusable if one doesn't sign into either Cloud or Server instance. I still cannot sign into to our self-hosted BB Server instance and had to use my Cloud account to get to any options in SourceTree. I am now able to use SourceTree locally and with Cloud but when go into Accounts tab in Settings and try to add my BB Server it refuses any combination SSH or HTTPS even though all login details work fine when accessing it via UI.

Like Jeremias likes this

This is making me crazy, unable to log in to our local bitbucket server, "login error", hours wasted :-(

 

Same credentials works just fine when loggin in from same computer to the web interface.

1 vote
denislutz I'm New Here Jul 16, 2019

Guys I can not use sourcetree because of this issue, I tried everything, really uncool!

If you just use the commandline to connect to the repo, over SSH (in my case) and then go into SourceTree, and instead of adding an account to your local Bitbucket (in my case) but instead just add a "local repo", browse to the local folder you just fetched, and viola you are in.
That kinda did it for me.

I have the same issue when login bitbucket using sourcetree too. Both method Basic username, password and OAuth. 

Let's hope we can get a resolution soon.

Have you tried using https://bitbucket.org/DU3O/<repositoryName>.git?
Oh, I'm sorry. This is not the solution, neither.

Hi John,

Thanks for the reply. I hadn't tried that, but it gives the same result. However I did try using https://bitbucket.org/DU3O/unrealsec3/src/master/ and that reduced the error to only Failed to check login for user [DU3O] so I guess that is what I should be using as the Root URL.

Thanks again

Eventually, I logged in directly with the Atlassian account and skipped the step of logging in to the Bitbucket server.

After doing that. were you then able to connect to your Bitbucket server?

I can join the Bitbucket account, but Bitbucket Server will still fail.

Hi John. I managed to get it working. This is what I done:

On the Remote tab - Add an account

Hosting Service: Bitbucket
Host URL: https://bitbucket.org/
Preferred Protocol: HTTPS

Authentication: Basic
Username: <my bitbucket username>

Hope this helps.

I had to do the same as Mark to get it working.

  1. Install and login to Atlassian account first
  2. In the remote tab, click 'Add an account...', same isntructions as Mark above
  3. Then you should see your repositories appear on the right
Like SAGOT camille likes this

Very confusing and unclear setup and help

Hello. I am trying to connect sourcetree to my bit bucket account. I believe I need to follow ACR Techstaff's Instructions, but I don't see a "remote tab". I see settings to change my email address, password, and avatar.There's also a section related to API tokens that I don't really understand, but I don't think it's relevant to me as I haven't set up two factor authentication. Am I in the wrong place? Where is the "remote tab"?

Sourcetree doesn't like the informations provided by bitbucket. There's no way to go on.
No "remote tab"...

No previous "atlassian authentication" via browser works...

No way to make it work

Installation and support are very confused.

Why should I need everything in order to install? Make me install, then troubleshoot, at least.....

Like # people like this

Atlassian is progresively going downhill - half-baked products tickets for critical issues unresolved for over 6 years and now this... awaiting competition who actually care about their cutomers and what they have to say to emerge!

I think the problem is that the windows client is asking for username but you log in on the web using either google login or your gmail account with it's own password I have no idea what the username's password is.

 

Why can't we just use our gmail or email account in the client.

0 votes

I give up.  I've just wasted the better part of an hour of my life trying to log in to install Sourcetree using our corporate hosted server using a valid URL and credentials just so I can test this tool out.  Epic fail.

Did you happen to read the Accepted Answer? Source Tree BitBucket Login to the BitBucket Cloud is only for their bitbucket.org address and not for onsite BitBucket Server installations. You can still use Sourcetree to access your Git repositories, you just have to do it the normal way, via a git:// address.

It sounds like you're trying to log into your local BitBucket on-premise Server using their bitbucket.org mechanism. That is not going to work.

We do indeed have an on-premise BitBucket server.  I access it in the form https://servername.domain.com and clone repositories from the command line using the form https://servername.domain.com/foo/bar/repo.git.  I already have the GIT repos cloned to my local machine that I want to work with, so I'm confused by the need to authenticate when installing Sourcetree to open them and am very frustrated by my inability to log in.  What "git://" address should I use?

I'm clicking the Bitbucket Server option when trying to log in and have tried all the following forms for the "Root URL:"

https://servername.domain.com/

git:https://servername.domain.com/

git://servername.domain.com/

For what it's worth, I have the exact same unresolved issue as Mike. I went down the path of creating a new account right there from the link It creates it just fine, and opens it in the browser, but never performs the suggested step of coming back to proceed through the installation sequence.  I'm guessing I have a DNS/proxy issue or am using the wrong browser, or am conflicting with my Tower installation, or... something else that Atlassian SHOULD have anticipated and handled before adding this level of inane security for a FREE product just to get a third or fourth version of our email address.

I'm starting to become pretty comfortable with Tower.

@Mike I downloaded the latest version and see that they changed quite a bit, especially the part about the Forced Authentication at the start. That's quite unfortunate. My apologies for not trying to again more recently.

Like Mike McCloskey likes this

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

1,710 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you