Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree refuses to use keychain

Hello!

Each time Sourcetree attempts to use my credentials for any account, OSX prompts me with a message informing me that 'SourceTree wants to use your confidential information stored in "github.com" in your keychain'  - If I hit "Allow" or "Always Allow", nothing happens. The dialog remains in-place for an infinite number of clicks until I finally press "Deny."

 

I've tried deleting my credentials, reinstalling sourcetree...nothing works. Any assistance would be really helpful!

12 answers

I appreciate that Atlassian has provided not even an acknowledgement to this issue, much less a solution.

@Brian Brown, I fixed this by removing all of my repositories and adding the ones I actually use again. Another answer clued me in that a repository containing a remote to which I no longer have access might cause a (still inexcusable) keychain password loop. After deleting all of my bookmarks (without removing the repositories themselves from my machine) I can confirm that I'm not getting any nasty keychain notifications anymore.

I hope this helps!
~Wes 

Thank you very much! That worked!

Temporary Workaround: I went into my keychain, found my github credential, and changed it to always allow access without password to that credential. Not super terrified of programs on my computer misusing my github creds...


That said, this is pretty crappy. Atlassian needs to fix this. Sourcetree continually asks for access, even when keychain reports that it has been explicitly allowed.

I've got the same issue - sourcetree 2.2.4. Ironically my github account works fine, but it's the Bitbucket one that gets stuck on keychain access. I've been able to bypass the issue by following Wesley Boynton's solution of allowing global access to the Bitbucket credential. Still pretty crappy.

It seems like Atlassian just does not monitor this forum at all?

This happens to me too.  I've tried exactly the same things you have.

Never mind. Removing my repositories worked for a while, but now after a full reinstall of sourcetree and a removal of all of my repositories, the problem has returned and is persisting.

Atlassian! Help, please!

I'm having the same issue. I've even reinstalled the app and it's still crashing when I try to access the "Remote" section. I've deleted everything related to git/github/Bitbucket from my Keychain and it's still crashing.

 

I'm using the terminal until it's fixed sad

I can confirm the problem and I also nearly tried everything to get rid of it.

Reinstall, deleting preferences, deleting all repos and all user specific settings.

After adding some repos again, the damn window pops up again and sawn on my nerves.

FIX: 

1. Download App Cleaner and trash everything related to SourceTree i.e. Application Support, Caches, Preferences (ignore the executable, which requires pro version). Close App Cleaner, you're done with it now.

2. Trash SourceTree from Applications folder manually

3. Restart your computer

4. Download SourceTree version 2.0.3 Download Now

5. Install, and everything should be golden (note: you'll have to add your local repositories again)

6. Yayy

In my case the problem was a thirdparty software (MagicPrefs).

To check this out, start your mac in safemode. Then open sourcetree and try if the problem is still there.

If not, you have to find the bad guy. First remove all startup objects in your mac user profile. If this doesn't help, a user or system extension could be the problem too (like in my case). 

Go to KeyChain Access on MacOs Applications/Utilities. You need to add credentials which the popup wants. 

Still happening despite trying the above solutions. Come on Atlassian!!

This is really annoying, because the popup stays in front of all windows, so you keep having to drag it out of the way. It seems to keep coming up until you quit SourceTree, and even then you have to dismiss it several more times.

I had this problem in the past, and eventually found a solution, which lasted quite a few months. But with the upgrade to 4.0.2, the problem came back. And now I don't remember the solution that worked last time. Argh. Atlassian, please figure out a fix!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,377 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you