Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,338
Community Members
 
Community Events
168
Community Groups

Sourcetree push is stuck with gitea repository

Hello,

I just installed SourceTree on my new windows PC, as I did on both a mac OS and another windows PC. I clone my repository from my gitea server and started working.

A few commits later, I try to push the commits to origin. 10s, 20s, ..., 2 minutes; nothing is happening, the push is not occurring and no error is raised.

I then tried to use the terminal:

    git push origin main

I am prompt 3 times for my combo username/password; and then the push does work. Everytime I push through CLI, I have to enter 3 times my combo username/password.

 

On the other laptops, mac or windows, I can pull or push through the GUI or the Terminal without having to enter my username/password (only had to do it when cloning the repo).

The server is accessed on my local network.

 

I tried adding a SSH key, it was disabled by default on my server. It doesn't change the behavior at all.

Any suggestion?

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events