Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,029
Community Members
 
Community Events
176
Community Groups

Sourcetree only showing default workspace repositories

Hello everyone,

since yesterday sourcetree is only showing me (remote) bitbucket repositories for one of my workspaces. I still can commit and push to cloned repositories on my computer but to clone a new one I have to follow the clone button on the bitbucket website.

Is anyone experiencing the same situation? Any way to fix it?

Many thanks everyone.

11 answers

Same here. Only the repos of my "Username"-Workspace show up. All others I have access to fail to show in this "Remote"-Tab of the bookmarks window.

I have the same problem. It worked before and now it is not working anymore.

My best answer right now is not to use the remote repositories list feature on sourcetree. What I do is hit he clone button on the bitbucket repository, ensuring https option (no ssh). This will allow you to open it by sourcetree and clone it as usual.

There has been a bug open for this for quite some time - https://jira.atlassian.com/browse/SRCTREE-5364. It is not getting much attention, so I suggest heading over there and voting/adding your comment.

Quite some time is such an understatement, version 2.7 yet where on ver 4.2
I found adding it via terminal ssh-add l to shows the added sshs. then ssh-add ~/.ssh/(name of private key) made the ssh version work for me.

Does anyone know what version of sourcetree where this does still work?

Same. Also getting this error when trying to "Publish to remote...". I think they're related. 

Loading Owners Failed

An error occurred while trying to load owners for account(* - Bitbucket). You can view the servers response below.

 

message: This endpoint has been removed. See our documentation for more information. https://developer.atlassian.com/cloud/bitbucket/rest/api-group-teams/#api-user-permissions-teams-get

Exactly the same here.  No more access to permissions on other teams/workspaces? That makes sense then.

No access to other workspaces, only my personal one.

Like Vikas Patel likes this

I'm also facing the same issue

same here...

I'm glad to hear it's not just me this is happening to. No idea what's wrong though. Thanks for pointing out some workarounds.

Unbelievable. After 4 months this issue still persist. I cant understand when a big engineering team can't fix this critical bug. 

Facing similar issue, earlier it used to list all workspace repository which I have access. Any solution ? 

Same problem. I can only see my 'username'-workspace.

Same here. The sub workspaces just disappeared from source tree a few days ago.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events