Sourcetree not starting on Windows 10

My Sourcetree (2.0.2.0.1) is no longer starting on my Windows 10 PC.

For a short moment (0.2 second) I can see a screen coming up and disappearing. Further no message, no error, nothing.

Re-installing didn't help.

(Weird thing: this version 2 runs fine on my old Win 7 PC, so I have a fall-back. Before I noted the older versions 1.9 were running only on my Win10 PC, but were hanging on Win7.  Why is Souretree so Win version specific?
With the current trend, I hope I don't have to search for a Win98 machine with Sourcetree 2.2....)

5 answers

This widget could not be displayed.

Hi Jan Peter! Have you tried with the newest version of SourceTree

A reason for this to happen is that the user.config file for SourceTree has been corrupted, can you follow the steps explained in the article SourceTree crashes on startup and let us know if this helped you?

If nothing of the above fixes it, can you send us the log?

Regards,

Ana

Hi Ana,

I downloaded the latest version, but that didn't help.
Under folder "C:\Users\janpe\AppData\Local\Atlassian\SourceTree" I find only 2 objects:
Empty folder "analytics_gas_upload"
and empty file "sourcetree.log"
No "user.config" file I can remove.

Log Name: Application
Source: Application Error
Date: 20/06/2017 17:04:29
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-53FQVVU
Description:
Faulting application name: SourceTree.exe, version: 2.1.2.5, time stamp: 0x59354ffa
Faulting module name: KERNELBASE.dll, version: 10.0.15063.0, time stamp: 0x461a0ff5
Exception code: 0xe0434352
Fault offset: 0x0000000000069e08
Faulting process id: 0x347c
Faulting application start time: 0x01d2e9d6726b0f8c
Faulting application path: C:\Users\janpe\AppData\Local\SourceTree\app-2.1.2.5\SourceTree.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: a1dc853f-3335-4dda-ab9b-9ee22719efbe
Faulting package full name:
Faulting package-relative application ID:

Log Name: Application
Source: .NET Runtime
Date: 20/06/2017 17:04:29
Event ID: 1026
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-53FQVVU
Description:
Application: SourceTree.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Runtime.InteropServices.COMException
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32, IntPtr)
at System.Management.ManagementObjectCollection+ManagementObjectEnumerator.MoveNext()
at SourceTree.Utils.WindowsOSHelper.GetWindowsVersion()
at SourceTree.App..ctor()
at SourceTree.App.Main()

This widget could not be displayed.
Mike Corsaro Atlassian Team Jun 27, 2017

Hello! It looks like the WMI may have become corrupted. Could you follow the steps here and let me know if you get a similar result (follow the steps up until the "WMI Control Properties" and post a screenshot)? Thanks!

Mike, thanks for your reply.
My WMI didn't have any errors, also winmgmt/verifyrepository returned Repository consistent.

I decided to retry "SourceTreeSetup-2.1.2.5.exe" once more, and now it continued to install this version..

Very strange, I didn't do anything different then the previous 9 times.. Anyway my problem is solved!

 

Mike Corsaro Atlassian Team Jun 27, 2017

Weird! Well, great to hear that it works!

Seems I was lucky for 3 weeks, now it stopped again.
I tried to re-install it, but also the install package (SourceTreeSetup-2.1.2.5.exe) fails.

 

I wonder: is there a (paid) stable and working Sourcetree version?

I'm not looking for freebies, if it means I'm only busy troubleshooting and re-installing it.

I do get some error reporting, should I post this here, or email to some support email address?

Mike Corsaro Atlassian Team Jul 20, 2017

Please post that error report here! Thanks.

During re-installation I got a "SquirrelSetup.log", but I can't post the content because your website doesn't accept the content ("Your reply was not accepted. Please check for inappropriate language of spam").

Further I got a report.wer, which can't be posted with same error.

So, where can I email this files to?

Mike Corsaro Atlassian Team Jul 20, 2017

Please email me at:

mcorsaro@atlassian.com

This widget could not be displayed.

I had the exact same problem and the only thing that worked for me was to unistall SourceTree, then delete my C:\Users\alfredo\AppData\Local\Atlassian folder and install the latest version.

It is working nice and perfect by now.

Hope it helps

This widget could not be displayed.

SourceTree 2.3.1.0 hasn't started anymore at my (two more colleagues) PCs.
Only small start-screen, then nothing.

Reinstalling 2.1.10.0 form download-archive helps to start (2.2.4.0 hasn't started, too): https://www.sourcetreeapp.com/download-archives

An in-app-update to 2.3.5.0 works after this.

Kind regards
Michael

This widget could not be displayed.

I ran into this same problem on Windows 10. Starting SourceTree would just bring up the small sourcetree window, and then quit. Looking at the event viewer log, I saw the Source: .Net Runtime and Source: Application Error that is referenced in this thread. Uninstalling and Reinstalling sourcetree did not result in any installation dialogs, but it did re-install. I tried deleting all the files in \\Users\User\AppData\Local\Atlassian\ and \\Users\User\AppData\Local\SourceTree\, but that did not fix the problem. After getting frustrated for a while, I finally attempted to install an older version of SourceTree, which said that there was a corrupted dictionary in \\Users\User\AppData\Local\Temp. I deleted the \\Users\User\AppData\Local\Temp directory, and then the new Sourcetree installer finally prompted me with the regular dialogs which let me re-install.

 

So if you're running into this problem, and the fixes above are not helping, you can try also deleting the \\Users\User\AppData\Local\Temp folder (along with the other folders mentioned) and see if that enables you to reinstall successfully.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

718 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you