Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

×
Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Sourcetree line endings for windows

My Git configs set core.autocrlf=input. 

 

I have it set this way in both "C:\ProgramData\Git\config" and "C:\Users\myname\.gitconfig

 

When I clone a repo from the cmd line, the line endings are not being changed, as expected.

But when I clone a repo in sourcetree, it is changing the line endings.

 

I do not want to set this on an individual repo basis either (and have not).

 

Any suggestions?

2 answers

use

git config --global core.autocrlf auto
0 votes
minnsey
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Sep 07, 2018

Hi Sourcetree should only attempt to set the autocrlf setting during installation and it will write it to the global config if it does.

If you run the following from the Terminal in Sourcetree

>git config --global -l

what setting does it show for autocrlf?

It shows:

core.autocrlf=true

Where is it pulling that from?  During install, I believe I selected the "input" choice.

minnsey
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Sep 07, 2018

From C:\ProgramData\Git\config I believe.inpout

I selected the "input" choice

When installing Git or Sourcetree? Sourcetree offers to set it to true during install, but there is no option to set it to input

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events