Sourcetree keeps crashing

Just from one day to the other my sourcetree keeps crashing and does not start again.

 

What I have tried:

  • Uninstalling and reinstalling sourcetree manually
  • Deleting sourcetree and atlassian folders from %localappdata%
  • Setting the AutomaticallyCleanUpDictionaryFilessetting in the user config file

 

Interesting fact about it: If I set the AutomaticallyCleanUpDictionaryFiles, reboot my machine I am able to launch the sourcetree setup wizard but it either crashs during the wizard or few seconds after launching the app. If I set the AutomaticallyCleanUpDictionaryFiles it crashs even before the UI becomes visible.

 

The log (in %localappdata%\Atlassian\Sourcetree) is beeing appended with the following line each time I try to launch sourcetree:

ERROR [2017-12-12 20:21:57,198] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied

2 answers

1 accepted

I had exactly same issue. Issue was resolved by uninstalling last Windows 10 update (KB4054517).

Windows Event Log was full of "Application Error". Update.exe (Squirrel) was failing in module "KERNELBASE.dll" and SourceTree.exe was failing in module "ntdll.dll", no specific message just "Application X failed in module Y". Every other program did not have any issues only SourceTree. Uninstalling last update did solve the problem. No errors in Windows Event Log anymore and SourceTree just works.

Version tested:
2.4.4.0 beta
2.3.5.0
2.3.1.0
2.2.4.0
2.1.11.0
2.0.20.1
1.10.23.1
1.9.13.7
1.9.10.0

Tried to delete folders in AppData. Tried AutomaticallyCleanUpDictionaryFiles. Tried everything. Every version failed in same way. Nothing but uninstalling KB4054517 solved problem.

I get the same error into the event log but sadly uninstalling the specified update didn´t fix the issue for me :/

 

<?xml version="1.0" encoding="UTF-8"?>
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-12-16T12:45:58.678547900Z" />
<EventRecordID>8811</EventRecordID>
<Channel>Application</Channel>
<Computer>Nep</Computer>
<Security />
</System>
<EventData>
<Data>SourceTree.exe</Data>
<Data>2.3.5.0</Data>
<Data>59d5304e</Data>
<Data>ntdll.dll</Data>
<Data>10.0.16299.64</Data>
<Data>493793ea</Data>
<Data>c0000005</Data>
<Data>000000000004be4b</Data>
<Data>1180</Data>
<Data>01d3766bd0ffe089</Data>
<Data>C:\Users\Daniel\AppData\Local\SourceTree\app-2.3.5\SourceTree.exe</Data>
<Data>C:\WINDOWS\SYSTEM32\ntdll.dll</Data>
<Data>0786924d-3af7-4266-99b1-6727cb3b7798</Data>
<Data />
<Data />
</EventData>
</Event>

Maybe you have some extra update? Look at recently installed updates. I also disabled updates otherwise Windows will install this update immediately again. Windows has cumulative updates so this update contains all previous updates. I did not update in a while so this error can be from previous update.

I also ran "sfc /scannow" (run in cmd.exe as administrator) and "DISM /Online /Cleanup-Image /RestoreHealth". These commands can repair corrupted Windows files. Also chkdsk can repair filesystem. Just for good measure.

Windows files have been all fine. I removed all updates back to start of the week and disabled windows updates for now. Seems to have fixed the issue, at least the app isn´t crashing any more right now. However this cannot be a permanent soloution in my oppinnion. Hopefully Atlassian will provide a fix for this. Do you know if they do read the community forums activly and record such issues or do they have an official bug support for such things? 

Disabling updates is not solution but I think this is a more Windows issue than SourceTree. I can't find any other examples of this error. Or any bug report on tracker. 

Looks more like machine/configuration specific issue than a generic error in SourceTree. Also ALL version of SourceTree are affected. I will guess some .NET framework/version issue on Microsoft side. I do not use many .NET based apps. This is maybe why everything works but SourceTree. Also errors occurs inside of Windows modules and not in SourceTree. This is why SourceTree log is empty.

Hard to say. Definitely weird bug. Not usual application crash.


Issue tracker is here https://jira.atlassian.com/projects/SRCTREEWIN/issues/ but reporting this issue is not trivial. My english skills are also very limited and my Windows logs are in different language. So I can't report this very well.

0 votes

Hi

Can you check what version you are running v2.3.5.0 should not crash because of the Dictionary files.

If you are running 2.3.5.0 and it still crashes can you see if there are any other ERROR entries, with stacktrace, in the log, perhaps by deleting the existing one before trying to run Sourcetree.

The ERROR you report above, is unfortunately just a miss categorized debug message.

Still giving me the same error. If I add the CleanUp property, reboot my pc and the app is launching and crashing afterwards it seems to log a different entry but without a stack. And without the cleanup property I only get the Squirrel log entry:

 

ERROR [2017-12-12 20:21:57,198] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-12 20:28:49,421] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-12 20:34:16,941] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-12 20:40:53,889] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-12 20:51:51,264] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-13 18:19:55,732] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-15 18:19:03,795] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-15 18:26:07,011] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-15 18:26:13,763] [1] [SourceTree.Notifications.NotificationsManager] [ShowNotificationDialog] - Unable to set owner as parent is not visible or non-existent
ERROR [2017-12-15 18:26:35,234] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-16 13:16:26,594] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-16 13:45:49,718] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-12-16 13:45:58,338] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied

 

Isn´t there any possible way of a 100% cleanup if there may be relicts of older versions or does removing the Sourcetree and Atlassian folders in localappdata 100% the job of cleaning up, too?

Other than any entries in Add/Remove Programs deleting the Atlassian and Sourcetree folders in localappdata removes all Sourcetree code.

Hey,

uninstalling the latest windows updates (so from start of december) and disabling windows updates fixed the problem as Tomáš Kolinger suggested. After Meltdown and Spectre become public I of course re enabled the windows updates and installed all the previous updates again and it did not crash any more. So I assume there really has been an issue with the special version of one windows update as removing it fixed the problem and meanwhile works again. Wouldn´t be the first time windows update makes other software crashing I assume ;)

Same here. I did nothing just re-enabled updates after a while a problem was gone. So some later update did fix this issue. Windows, yaaaaaay!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

848 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you