It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree is showing a red exclamation mark next to 'Remote' button since updating to version 3.0.6 Edited

Here's a picture of what I'm referring to:

Sourcetree-Remote.PNG

How do I get rid of this warning symbol? If I click on it, I get the message "You don't have any remotes which have extended integration settings configured; you need to edit your remotes to add details such as the hosting type and base URL. Click the Settings button to open your remote list".

If I do just that and edit my origin remote, the only host types being offered are BitBucket, GitHub and Stash - none of which my project is using, so I can't actually do what I'm asked.

Anyway, why do I need to add a hosting type? This seems like a new feature that'd be convenient for a lot of users, but not something essential. Why throw a big red warning sign at me over this - making it the center of my attention for up to an hour now - when nothing is actually wrong?

I don't want to use extended integration, I just want to get rid of this warning sign because it's a major distraction.

It's basically the same issue as the constant "Git LFS is not supported" nagging when I don't use Git LFS, but at least you could dismiss those messages. This one doesn't seem to want to let go, ever.

12 answers

13 votes
minnsey Atlassian Team Oct 22, 2018

Hi

After feedback we are going to be softening that warning in a future release. Thanks for making the effort to report it.

Maybe allow people to pick "Other" or "not on list" or something so you can take suggestions for other systems (if they exist?) or just go away for sites that are hosted locally!? I mean GIT IS a distributed source control system... so why suddenly do you think it NEEDS a central server and what's worse is one you deem worthy? ;p 

Like # people like this
minnsey Atlassian Team Nov 07, 2018

Hi

Thanks for the suggestion. As you say it doesn't need a central server, but parts of the extended functionality, e.g links to creating PRs etc rely on having a remote server configured.

Yes and I love and worship it for that stuff! 🙇‍♂️Please don’t think otherwise! It’s amazing for a paid app never mind free!

BUT the red exclamation I can’t “fix” for other stuff without a server is making my brain twitch! 🤪 LOL

Just the ability to say “yes thanks I know” for a repo would solve it.

Like # people like this

I agree with Gareth. Sourcetree shouldn't constantly annoy me with this suggestion when it's nothing I can actually fix, e.g., I'm using Azure DevOps instead of GitHub or BitBucket.

 

Side note, due to this and other annoyances, I've switched to GitKraken for now.

Like # people like this

This is still not fixed in 3.0.9. Will you please remove that big ugly red exclamation mark? I use my company's private git repository and I don't need any "extended integration settings". Please.

Like # people like this

Yes, please fix it with the softening you describe!  Thanks.

Until then, this bug looks VERY BAD when I demo SourceTree to colleagues in hopes of convincing them to use it - a big red exclamation that cannot be fixed makes prospective new users nervous!  They think something is actually wrong, and are not comfortable enough to start trying SourceTree out for themselves.

This makes SourceTree look bad!

 

UPDATE:  This seems to have been fixed (at most with 3.1.1).  Thanks!

Like # people like this

Any time frame for when you'll have a fix ready? The red exclamation mark is very annoying.

minnsey Atlassian Team Feb 05, 2019

It will be in the next major release which we are currently finalizing. I'm not going to commit to a specific date at this stage :) but it should be before Easter.

Like # people like this

One year later, and the red warning icon is still showing (version 3.3.4).

Like # people like this

Funny, started appearing the first time after updating to 3.3.4 after the last >15 updates I think

@minnsey The Easter Bunny is almost preparing for his next appointment. What's the status with that major update you were talking about?

Like # people like this

Anybody trying to fix the big RED exclamation mark yet ?

I had the same issue and was able to fix it by recreating my origin:-

Go into Repository/Repository Settings, select your origin & edit.

In my case I made a not of the URL then removed the origin then re-created it with the same URL and I also had to change the remote account in Optional Extended Integration from Generic Host to my Bitbucket Server.

Hope that helps.

Like # people like this

Also just upgraded to 3.3.4 and began receiving the Exclamation Mark of Impending Doom.

Interestingly when I click it I get a message from windows telling me I need to get an app from the app store to open an ssh link.

I seem to be able to fetch from the repos without issue.  We have Bitbucket server as our main repository, and as you might guess from the above error, I use ssh to connect.

Deleting and recreating the "Remote Repository Path" from the Repository settings (as suggested by mbandy) did not help.

I was able to get rid of the E.M.o.I.D. by going into the Repository settings and changing the Host Type from "Unknown" to Bitbucket server and putting in any URL at all.  I even tested "http://fake.com/" and the E.M.o.I.D. goes away.

That being said, it makes the button worthless. I was able to get the button working by going to my Bitbucket server and getting the clone URL, specifically the HTTP clone URL, not the SSH url and using that without the final slash and repo name (ie the clone URL of "https://a.b.com/abc/my/repo.git" becomes "https://a.b.com/abc/my".  With that setting the "Remote" button opens a browser directly to my Bitbucket server project.

Hope this helps someone.

Like # people like this

Going in and changing the Remote Account solves the issue, but it's not saved and the problem reappears after a restart of SourceTree...

Like # people like this

Further to my previous comment, I can confirm that the same happens to me. If I re-start Sourcetree the remote account resets and I'm back to square one. 

Like # people like this

I just got the big red remote of doom as well after updating to 3.3.4 today.

Clicking on it - opens my github page, with absolutely no problem. Remote operations appear to be working fine.

Going into repository settings says the host type is github

Do you guys test this stuff?

Like # people like this

I can confirm that changing from "Generic Account" to specific account helps but it doesn't that setting. 

Seriously, do you actually ever get beta testers to test this stuff? It just appeared yesterday when I upgraded to 3.3.4.

I'm on 3.3.8 with the same settings as my coworkers. I get the issues addressed above, they do not. Is there a fix to this issue yet?

Like Ben Ward likes this

Nope.  :-(

One workaround is GitHub Desktop, which is very well maintained by a highly responsive team, and much more frequent bugfixes.

Like YJ Huang likes this

I upgraded to 3.3.4 this morning and got the red exclamation mark.  After searching through the above threads, I went to the main menu "Repository" item, selected Repository Settings and selected my repository origin (we have a private Bitbucket server). 

I clicked "Edit" and then under Optional Extended Integration selected Bitbucket (it was set to Unknown or whatever the default was before).  The red exclamation mark went away.

Just FYI I've been pretty happy with Sourcetree so far.

What happens when you close SourceTree and open it up again?

Like Pedro Mota likes this

Ah, the exclamation mark re-appears and I have to repeat the process.  Also, the default appears to be "Generic", not Unknown.

Like # people like this

Yeah, that's what mine does, too. There doesn't appear to be a way to save it...

Like # people like this

I hadn't noticed it because I typically only start Sourcetree after rebooting my machine, which usually only happens when IT decides to periodically "re-educate" my laptop :)  Otherwise I just hibernate instead of shutting down.

Mostly just a cosmetic thing, but the red color could be alarming to users.  If I had serious OCD it might actually bother me ...

Like # people like this

Same situation here. Is there official info about this?

Same problem but I cannot get it to run a workaround...all my work is just hanging out, ready to be committed. Is there a fix yet?

Are we dealing with more than one issue here? 

In my case, I get the exclamation point and it is fixable in the way others have described (except the fix only lasts until the next restart of the program). However, the issue is only cosmetic as the program still seems to work regardless of whether I have the exclamation point or not. It seems like, perhaps, for others the exclamation point also implies a non working state making the issue different than what I am seeing.

Or are we dealing with one issue that manifests in two different ways?

  • For some configurations, the setting is actually not needed for function (generic setting works fine) so problem is only cosmetic (my case).
  • For some configurations, the setting is actually needed (generic configuration will not work) so the problem is functional (other cases?).

I should note, however, that at one point I did have a functional issue. I kept removing things in windows that seemed related to Sourcetree authentication until Sourcetree started working. However, as I noted, the exclamation mark issue did not go away (though I don't much care as long as pushing and commit work).

Agreed. I'm still using 3.3.4 (have not been prompted to upgrade in a long time) and still use SourceTree all day, every day.  Works fine for me, and saves a lot of typing over having to use Git Bash :)

That said, I read somewhere that later versions might have other issues.  Maybe that is why I have not been prompted to update yet ?  Are there "stable" vs. "development" versions that people are using ?

Considering all the other problems I have to deal with on a daily basis this seems like a pretty small issue.

About a week or so ago I noticed that I couldn't fix the red exclamation mark anymore, running 3.3.8.  I just upgraded to 3.3.9 this morning, and the same thing. 

The repository settings show the repository as "Generic", and there is no choice for Bitbucket.  Hmm ...

That said, I know IT upgraded our Atlassian server software recently -- we got new goodies in our pull requests, for example.  Maybe there is some kind of server incompatibility with 3.3.9 ?

I still consider this to be cosmetic, and I bet if the color wasn't red almost nobody would notice it.

It is not "cosmetic" at all for me. Until I change the "Optional Extended Integration" account to my BitBucket account, simple git operations work but I can't initiate a pull request (from within SourceTree).

True... the workaround isn't complicated, but it's very annoying that Atlassian is taking so long to do nothing about what seems to be a clearly defined and very annoying bug.

Interesting, I've never actually done a pull request from Sourcetree before -- I just use our Bitbucket server for that.

So I tried it -- I right-clicked on a branch, and selected "Create Pull Request ..."; it came back with a dialog which said I had to fill in the extended integration details under repository settings.  I did that, set the type to Bitbucket Server, filled in the base URL with our corporate Bitbucket URL, and my username.  The red mark went away.  Okay, good !

Then I was able to do the pull request, BUT all it does is go to our Bitbucket site and do the couple keystrokes that I would have done manually.  That is kind of neat (but it's hardly a miraculous time-saver).

And of course the settings do not persist, once entered. That is a little annoying.  I'll llive, though :)

Yep. You found it. I agree. "Annoying" is the right word... and I've been living with it for nearly two years, so obviously it isn't fatal.

But again... "annoying."

Min Hu I'm New Here Aug 04, 2020

Thanks, it solves the problem. But I just hope Sourcetree could solve it by default.

Over a year and a half later and this clearly defined bug with a huge annoyance level and high number of impacted users remains a problem.  It's quite shocking and even a bit concerning about the Atlassian ecosystem as a whole.  I mean... if they have such trouble solving such a clearly defined issue... I just don't know...

Further, I know ST is a free product but it sure would be nice if those of us who actually pay for Atlassian's other products didn't have to go elsewhere for a Git client because of small bugs that the company won't prioritize.

I am not updating the tool because of this bug. For sure I can't understand either how this situation is possible...

Like # people like this

Same here. I've just upgraded to 3.3.4 and have the exclamation mark. If I click on remote I receive an error (Unable to open your web browser etc). If I have my web browser open at the time it shuts down.

For me, it open a screen asking to select an app in the Microsoft Store with the message "you'll need an app to open this ssh link. Look for an app in the Microsoft Store".

Why it would do that I don't know. I would think whatever action the button is intended for, should be done from SourceTree? Like open the Repository Settings dialog maybe.

2 votes

Bug is seen.

TLDR; exclamation point goes away with this change but change does not stick after a restart.

Using  3.3.8.3848 here. Issue "goes away" after 'Optional extended integration' setting for remote account in 'Remote details' of repository paths from 'Repository settings' is set to "Bitbucket Server" instead of "Generic Host".

Exclamation point on button comes back after restart. Previously set setting is not sticky and can be seen to have reverted to "Generic Host". Despite this, pull & push functionality seems to work.

I have  the same exact issue.

Like Ben Ward likes this

Good luck. There seems to be no hurry on the part of Atlassian. We've been waiting for a fix for over a year and a half.  They haven't even COMMENTED on it in over a year.

true, this seems like it should be an easy fix for them. For a while I've just been leaving SourceTree open all the time. Then I don't need to think about it, unless I have to restart... then I change from Generic to specific account and leave it open.

Like Ben Ward likes this

same problem here. Just upgraded to 3.3.4 and the remote icon is showing exclamation mark.

When doing the following steps the exclamation mark goes away but restarting sourcetree gives the same problem.

  • main menu Repository item
  • selected Repository Settings
  • selected my repository origin (BitBucket)
  • click Edit
  • click Ok and Ok
  • The red exclamation mark went away.

Even with the exclamation mark everything seems to be working fine but it's annoying.

My experience (and that of others) is that it comes right back again the next time you start sourcetree.

Like Steve Melnikoff likes this

I'm having the same problem with version 3.3.8.

@Jasmin Letendre  suggestion: you can use version 3.2.6, it doesn't have it

Like Jean_Pierre_Tosi likes this

I'm still debating whether to rollback to 3.2.6 or not. The upgrade to 3.3.6 (then 3.3.8) was a disastrous experience:

- Display that is not refreshed anymore (SRCTREEWIN-12705, fixed in 3.3.8)

- Open Terminal not working anymore (SRCTREEWIN-12853, fixed by upgrading git from 2.21 to 2.25)

- Crash every time I clone a new repo (still not fixed).

- Repo config that is lost every time SourceTree is restarted so I have to reconfigure as a BitBucket server every time (related to SRCTREEWIN-10820)

version 3.3.8 has the issue yet

Like # people like this

I have experienced all the same issues as @Jasmin Letendre mentioned above. I also experienced an issue where when cloning our master it threw errors due to file name length. So, I had to go into GIT BASH and override the filename length to get it to correctly clone the master.

Like Dominick Sidiropoulos likes this

For what its worth  - 

  • Tool > Options > Authentication > Add account
  • Choose hosting service, protocol and authentication
  • Login using OAuth or PAT
  • Once logged in - Go to Repository > Repository settings
  • Click on Remote repository path > Edit
  • Choose your authenticated Remote account from Dropdown > OK
  • Red exclamation mark will go away!

Have you tried closing and opening Sourcetree afterwards?

Like # people like this

Yeah...try closing SourceTree and then let us know if your solution works.

Like pablo_laplace likes this

I followed these Steps, 

Closed then  reopened SourceTree and the Exclamation point was right back.. Goes away temprarily

2020-03-03 11_12_27-Settings.png

Wow.. didn't check that. Yes, it comes back and the Remote Account under extended integration is reset to "Generic Account" instead of the one I had selected. This is super annoying. I am running version 3.3.8.3848

This really needs a fix.

Like # people like this

Just to update - The red exclamation marks do not appear in two of my other machines running Sourcetree versions: 3.3.7.3839 and 3.3.6.3829

I "Checked for updates" under options to update the Sourcetree but gives me a green light saying "Sourcetree is up-to-date". Why is it not picking up the update for 3.3.8? (Probably better that way)

I just tried the last version, and it keeps with the same error for me.
I don't understand how you get a green light if you have an old version

Like # people like this

What is your version @Pedro Mota ? I am not sure why there are inconsistencies with different versions? Just baffles me.

Like pablo_laplace likes this

I suspect the auto-update feature of the software may be broken as well?

I have not seen any updates for some time, and I am running version 3.3.4.
That is not the latest version, as far as I know.

However, in the about screen there is no "Check for updates button" anymore.
So the only way to check for updates is apparently to download the latest manually.

The issue with the red exclamation mark has now persisted since late 2018.
I am not sure Atlassian is actually fixing any bugs in their product currently?

Like # people like this
1 vote

I have the same problem, but when I click on the icon it takes me to my BitBucket repository site which never loads up unless I refresh the page

Same issue here.

Really a surprise to see so many people have similar issue for such a long time, while no solution was offered yet. 

Like JohnKNess likes this

$42B market cap... definitely resources to get this fixed.  Let's do it!

0 votes

O bug infelizmente continua na versão: 3.3.8

SourceTree 3.3.9 [26 May 2020]

Changes

  • Security fix for embedded Git
  • Added org listing to remotes page to reduce network calls for hosts with many orgs
  • Fixed issue with installer not creating a shortcut
  • Fixed issue with installer not checking for updates

 

I didn't try but I guess there isn't a fix for it

I just updated to 3.3.9... same problem.  The Optional Extended Information -> Remote Account resets to generic (and has the red exclamation point) upon close/open of SourceTree.

Like # people like this

OK. I shot them a Twitter message regarding this thread and got this back - 

"Hi Deepak - thanks for getting in touch with us. We've reached out internally for some additional insight from our team, and will circle around with any updates! Appreciate it. -MP"

Hope there is a solution to this annoyance soon.

There has already been an ATLASSIAN TEAM here, not sure if it would be the solution.
because of the old issue, I am still using v3.2.6

Like dshakya likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,907 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you