Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,569
Community Members
 
Community Events
176
Community Groups

Sourcetree install asks for bitbucket account

Greetings,

I downloaded windows version of source tree and tried to install it in windows7 enterprise.  According to your documentation install requires only an account in Atlassian.  However, during install it asked for bitbucket account. Did I download wrong version?  Can you please advise why a bitbucket account is required to install source tree?

 

Thanks!

1 answer

As of version 3.0.7 Atlassian removed the option to sign up using an Atlassian ID (see Sourcetree release notes), you now need either Bitbucket Server or Bitbucket Cloud account to complete the install. You could download 2.6.10, complete the install using an Atlassian ID and then upgrade to the latest version.

Thanks Mikael. In the download archive available versions are 2.6.3 and after that 2.7 but  not the 2.6.10. Release notes of version 2.7 starts with Bitbucket Pipelines and Migrate to Bitbucket Cloud. I am leaning towards installing 2.6.3 and then upgrade to latest version and test drive.  Will I be able to migrate to latest version from 2.6.3?

Mikael Sandberg Community Leader Nov 28, 2018

Those are the Mac OS versions you looked at, you have to scroll down to see the Windows ones, or use the direct link I included above, 2.6.10.

Yes..I realized that.  I found  2.6.10 for windows. I will try installing it and then upgrade to latest version and see how this goes.  Thanks for your help. 

Greetings.  I tried to install windows 2.6.10.  Went through registration and sign up to Atlassian account.  Then screen open to download tools. The options are Git and Mercurial.  We have Gitlab and my purpose is to get a Windows GUI client.  I take it I should download Git?  Is this correct? please advise.  Thanks for your help.

Mikael Sandberg Community Leader Nov 29, 2018

It depends on what version of Git you want to use. Sourcetree comes with an embedded version (that is the one that will be downloaded) or your can download and install a system git version (I use the one from https://git-scm.com/). You get the question about downloading Git/Mercurial if you do not have those installed already. If you do not plan on using Mercurial you can choose not to install that one.

So, in order to get past download screen I should opt for Git and ignore the embedded version that will be downloaded?

Mikael Sandberg Community Leader Nov 29, 2018

It is up to you. You can always switch to use system git after the installation is done, just go to Tools > Options > Git

Options.png

OK...one last question.  We have our own gitlab instance - https://ourgitlab.com/users/login --> how do  I connect to it?  I don't see any option to connect to the gitlab instance we have.  Thanks for your help.

Never mind, I figured it out. 

Under Options > Updates it says:

"Sourcetree will automatically update, but you may also check manually for new updates"

But check for update is greyed out.

Mikael Sandberg Community Leader Nov 30, 2018

You can always download the latest version from https://www.sourcetreeapp.com/ and run the install, that will just upgrade your current version without having to register the client again.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events