Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,451
Community Members
 
Community Events
176
Community Groups

Sourcetree ignores github token and throws 403 error

Edited

I have generated personal token on github and entered it in password field successfully, but when I try to fetch from my repo sourcetree throws me following error:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks fetch --no-tags Room
remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.
remote: Please see https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information.
fatal: unable to access 'https://github.com/daisoto/room.git/': The requested URL returned error: 403

I have tried deleting my accounts from sourcetree and logging in again, but I still receive this error.

 

However, if I use console there is no error. Is proves that there is some error or my mistake in using sourcetree account managament.

4 answers

1 accepted

17 votes
Answer accepted

I had the same issue and solved it in this way:

Open sourcetree, in the right click icon Settings (Repository settings) ->Remotes -> Select Origin and Edit:

Set URL/Path in the following format:  https://<token>@<git_url>.git

works for me too. Thank you!

Like # people like this

Thanks a lot for your solution!

 

Yet I have certain fear about this one, if someone gain access to your sourcetree client, they will easily find your token.

Like RU-GHETES Mihaela likes this

Hi @Владимир ,

 

Even if it's not a nice one, that was the solution that got me out of trouble.

If you'll find another solution, please share it with us.

 

Thanks ,

Deleted user Aug 19, 2021

<3

It woks on Mac. Thank you.

This is actually a workaround of a bug. The bug is, even if you remove/change the old authentication method, the SourceTree will still try to use the old one. It is restored even if you uninstall and make a fresh install of the app.

To prevent this after removing the old git credentials, delete Atlassian folder from all the appdata folders. Then go to Tools->Settings->Authentication and add a new Basic Github authentication. Enter the Github username(not the e-mail) and use your token as the password. It should work after that.

Like # people like this

This workaround works!  Thank you SO much!!   Sourcetree needs to get this issue fixed ASAP.

Changing the url only works for me

@Abdullah Çınar I delete passwd in AppData\Local\Atlassian\SourceTree and use token to login again. It works.

Like todagami likes this

@jack_lin this works for me!

Abdullah Çınar's solution has worked for me twice now. Once last year but I recently had to re-install Windows due to a system issue. I had forgotten how I had solved this issue before but thanks to a friend linking me to this thread, Abdullah Çınar helped me again.

Delete your passwd file in \AppData\Local\Atlassian\SourceTree\

There are many different issues you might face.

We have tried to dig into each of them and resolve them all finally.

This article could be helpful for you: https://howieyoung.medium.com/suffering-from-the-latest-403-error-from-github-on-sourcetree-e04a844efd35

I use SSH-based authentication. It works.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events