Sourcetree doesn't reopen project at startup

I have this option checked in settings, and it used to work, but it doesn't anymore. Stopped working after I deleted my mercurial repository and created a git. Now I always get the bookmarks window showing a single repository.

8 answers

1 accepted

3 votes
Accepted answer

OK thanks, I understand. Please consider this a feature request: allow the user to override this system-wide setting. I really don't want Preview or Word reopening old docs, but I always use sourcetree on the same projects.

Thanks, Jonathan

The update for this will be released in version 1.6.3 this week.

This is very bad. Please set it back to the way it was. I "hate" that MacOS X tries to open all my windows on restart of a an application, thus I've turned this feature off.

As a consequent SourceTree does not open my Bookmark window anymore. Meaning, every time I open SourceTree I first need to go to "View" and "Show Bookmark" and then click on one of my 30 repositories.

Why the extra clicking? Why change it to Apple's standard? That is/was anyhow one of the worst "features" in MacOS X.

Hi Nitai,

We totally understand and agree with you. A fix for this will be issued and will be released as part of 1.6.3 which should be out soon.

Thanks for giving us the feedback, we really appreciate it.

Cheers

I share the same opinion

Can you give some more details please:

  1. What version of Mac OS X you're running
  2. When you deleted one repo and created another, was the path the same? If so did you re-import it to the bookmarks?

Sure:

1) OS X 10.8.4

2) Yes, deleted Hg repo and created git in same directory. Don't remember what I did with the bookmarks.

I just deleted the bookmark, opened the repository, and it asked to create a bookmark, and I let it. Still doesn't auto-open.

Thx, Jonathan

Hi Jonathan,

We changed the way window re-opening works in a recent version as it now abides (correctly) to your OS preferences instead now. If you go into System Preferences and go to the General settings there's a "Close windows when quitting an application" setting. If this is turned on then your windows won't be restored on startup.

The preference in SourceTree was left behind for 10.6 users, however this will now be disabled in the next release of SourceTree for users using 10.7+ as it's no long applicable. We correctly adhere to the system preference instead now.

Hope that helps

Hi Kieran,

This is very good news. I relay on ST every day. Thanks a lot and thank you for giving us such an awesome tool.

Great! =)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

715 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you