Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,802
Community Members
 
Community Events
168
Community Groups

Sourcetree does not list private GitHub repos

Edited

I've added my GitHub account to the remote repositories in Sourcetree. Much to my surprise, I cannot see my private repositories.

After some research, I found out, that the API call to https://api.github.com/users/<username>/repos only lists my public repositories - and this is what Sourcetree seems to call.

A call of https://api.github.com/user/repos?access_token=512295a0afb73bdd1c076a00c69f8abcd12345 (fill in a valid Access Token) instead shows all public/private repos.

 

Can you please add the option to specify an access token, so that private repositories are listed as well?

1 answer

1 accepted

0 votes
Answer accepted
minnsey Atlassian Team Feb 26, 2019

Hi

Which version of Sourcetree are you using?

Sourcetree for Windows will add credentials, but via headers rather than as part of the query string.

Hello,

I am using version 3.0.17 on Windows.

minnsey Atlassian Team Mar 12, 2019

Hi

I've tried reproducing this but currently I can't.

Are the private repositories ones you own or ones you have access through an organization or owned by others? 

Both - and unfortunately I am shown neither in Sourcetree.

 

Have you tried to setup a private repository in Github and did it show up in Sourcetree?

Hi

We have identified the issue and have a fix in progress. It probably won't make the next release but should be in the one following.

It wasn't immediately obvious as we have a large number of repositories and the privates ones do show up when you search.

Mike

Like Daniel Pfeffer likes this

I'm glad you could reproduce what I was experiencing.

 

And in fact, I get my private repositories listed, when using the search function.

Looking forward to the fix.

Just to hop onto the back of this, I have experienced the exact same issue and I can successfully search for my own private repos but I cannot see a private repo that I have forked from another user.

minnsey Atlassian Team Apr 04, 2019

Fix should be going out to Beta testers in the next few days.

Like Nathan_Watson likes this

Any update on a fix for this @minnsey  I added my Github account to Sourcetree today on my Mac and I'm unable to view the private repos I own on Github

minnsey Atlassian Team May 16, 2019

I believe the fix is now released for Windows, for mac can you please raise an issue at https://jira.atlassian.com


Like tonydehnke likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,652 views 134 29
Read article

Atlassian Community Events