Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree crashes on start after adding a new repository

Everytime I am adding a new Repository to Sourcetree, Sourcetree crashes. When I delete the repository again Sourcetree works. So I am not able to add a new repository. Any ideas what I can do?

5 answers

1 vote
Manju Atlassian Team Jun 06, 2018

We are investigating the crash with https://jira.atlassian.com/browse/SRCTREE-5762. There seems to be an issue loading and reading repo avatars. We will soon have an update on this. Thanks for your patience! 

Manjunath
Sourcetree Mac Developer

Thanks for the quick reply!

1 vote
Manju Atlassian Team Jun 06, 2018

Please feel free to remove the ImageCache folder under ~/Library/Application Support/SourceTree/ for now. We are investigating this crash and will have an update soon.

Thanks for your patience! 

Manjunath
Sourcetree Mac Developer

Hey Manjunath,

I deleted the folder, but it still crashes... Are you sure its because of this?

Thanks,

Julian

Manju Atlassian Team Jun 07, 2018

Yes, it was due to fetching repo avatars. It wouldn't crash only until it tried to fetch again. 

This was primarily due to a change deployed by Bitbucket cloud that was reverted in time. Also, we made a release of macOS client to ensure this type of a crash doesn't happen again. Thanks for the understanding and kind cooperation. 

Cheers,
Manjunath

Someone suggested this issue might be related to another one a bunch of us are experiencing with crashing on startup. For us the browser.plist and a few other files seem to be the culprit and as long as I don't make bookmarks I'm able to work.

Please see here for discussion of what's happening with crashes:

https://community.atlassian.com/t5/Sourcetree-questions/Sourcetree-crashes-on-startup-on-MAC/qaq-p/813621#M22472

I deleted now the entire "~/Library/Application\ Support/SourceTree/" folder and now it seems to work again... 

You should check to make sure that committing a repo doesn't cause a crash. And also see if you can add bookmarks without a crash.

Because initially when I deleted the entire support folder it appeared to work without crashing but the first commit made it crash. And then any attempt to launch the app after that also resulted in crash.

For me deleting the entire support folder was temporary and incomplete fix but if I tried to add a bookmark it'd crash. Removing the browser.plist file made it work again as long as I don't add any bookmarks.

I'm currently able to commit etc. but I have to make sure not to create bookmarks.

I tested pulling and comitting and it works. I also created Bookmarks / Repository Groups if you mean this. And it works for me!

0 votes

I faced the same issue and had a lot of trouble finding a fix for it.

I tried:

- Removing suggested files from application support folder

- Removing application support folder for source tree

- Re-installing the latest version

- Installing a old version

None of the above worked, It was crashing as soon I add my local repo to source tree and try to open it.

I also tried to use another repository and it was working fine, SO I concluded problem is with my local repository, I started deleting files from git folder and finally it resolved the issue.

You need to remove these two files from .git folder:

  1. sourcetreeconfig
  2. config

I would suggest to take the backup of local repo and then try deleting these two files and add the repository again, this time the source tree didn't crash for me.

Hope that works for you !!! :) 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,280 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you