Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,422
Community Members
 
Community Events
165
Community Groups

Sourcetree crashes on moving repository into group

Hello dear community,

Sourcreetree (MacOS 10.15.1 (19B88)) crashes on moving repository into group.

Here find the exception details.

Best regards,

Thomas

 

Process: Sourcetree [16776]
Path: /Applications/Sourcetree.app/Contents/MacOS/Sourcetree
Identifier: com.torusknot.SourceTreeNotMAS
Version: 4.0 (229)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Sourcetree [16776]
User ID: 501

Date/Time: 2019-11-01 12:43:48.487 +0100
OS Version: Mac OS X 10.15.1 (19B88)
Report Version: 12
Bridge OS Version: 4.1 (17P1081)
Anonymous UUID: D68B3CE9-5354-3074-600B-1A7838F88AD4

Sleep/Wake UUID: CE78A0E7-68D1-4C5E-BB7F-8A929A3C9DFA

Time Awake Since Boot: 9100 seconds
Time Since Wake: 4100 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [16776]

Application Specific Information:
Crashing on exception: There are 2 items on the pasteboard, but 1 drag images. There must be 1 draggingItem per pasteboardItem.

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff38205f53 __exceptionPreprocess + 250
1 libobjc.A.dylib 0x00007fff6e2cb835 objc_exception_throw + 48
2 CoreFoundation 0x00007fff38205da9 +[NSException raise:format:] + 189
3 AppKit 0x00007fff356943bb -[NSDraggingSession(NSInternal) _initWithPasteboard:image:offset:source:] + 247
4 AppKit 0x00007fff35693dee -[NSCoreDragManager dragImage:fromWindow:at:offset:event:pasteboard:source:slideBack:] + 1889
5 AppKit 0x00007fff3569367d -[NSWindow(NSDrag) dragImage:at:offset:event:pasteboard:source:slideBack:] + 134
6 AppKit 0x00007fff35a1aee1 -[NSOutlineView dragImage:at:offset:event:pasteboard:source:slideBack:] + 198
7 AppKit 0x00007fff35b1b48d -[NSTableView _doImageDragUsingRowsWithIndexes:event:pasteboard:source:slideBack:startRow:] + 656
8 AppKit 0x00007fff35b1b920 -[NSTableView __doImageDragUsingRowsWithIndexes:event:pasteboard:source:slideBack:startRow:] + 276
9 AppKit 0x00007fff35b1c62a -[NSTableView _performClassicDragOfIndexes:hitRow:event:] + 452
10 AppKit 0x00007fff356be7ae -[NSTableView _performDragFromMouseDown:] + 472
11 AppKit 0x00007fff356bcc33 -[NSTableView mouseDown:] + 754
12 AppKit 0x00007fff356bc74e -[NSOutlineView mouseDown:] + 73
13 AppKit 0x00007fff355635e9 -[NSWindow(NSEventRouting) _handleMouseDownEvent:isDelayedEvent:] + 4907
14 AppKit 0x00007fff354a6eb0 -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 2612
15 AppKit 0x00007fff354a623d -[NSWindow(NSEventRouting) sendEvent:] + 349
16 AppKit 0x00007fff3536a45c -[NSApplication(NSEvent) sendEvent:] + 352
17 AppKit 0x00007fff35359da7 -[NSApplication run] + 707
18 AppKit 0x00007fff3534b95d NSApplicationMain + 777
19 libdyld.dylib 0x00007fff6f62e2e5 start + 1

 

9 answers

I am also experiencing this issue when dragging repos in the Repository Browser window. It happens in both 4.0.229 and 4.0.232 on macOS 10.15.2.

I am receiving the same crash when dragging files from unstagged to the index. i experience this on both 4.0.229 and 4.0.232

I get this when I was on SourceTree 4.0.0 but I was updated to the SourceTree 4.0.1. and the issue was resolved. 

I get this error as well on macOS 10.15.4, SourceTree 4.0.1 (234).

It appears here when trying to move (or right click) on files in "Unstaged files".

Same here, happened after upgrade from 3.X.X, any solution?

mac 10.15.3 running SourceTree 4.0.1 (234) solved it for me. 

just installed the latest update, 4.0.1(234). This is still an issue. I am running catalina

I have the exact same crash... 

On the beta, it works as intended. Using it now for a while.

I had the same issue on MacOS 10.15.2 on Version 4.0.229.

An update to 4.0.232 solved the issue on my machine.

I am also experience similar issue when try to stage files on repository.

 

Sourcetree version 4.0 (429)

MacOS 10.15.2

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

60,648 views 127 26
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you