It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree, cannot clone/pull anymore. sh.exe.stackdump

Anders Hvid Nov 12, 2013

Well since yesterday I haven't been able to Clone any new Repos and I haven't been able to pull from any of the once I have been using. Everything worked fine before but it seems (to me) that it randomly stopped working.

I also noticed a file named "sh.exe.stackdump" is being created in every repo I have cloned, no idea where it came from

Here is an example of an error I get when I'm Cloning, I have no idea what they mean so I was hoping to get some help here :)

git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive https://github.com/UglyOldGuy/BoL e:\Users\Saftsnubben\Desktop\Buckets\Test
Cloning into 'e:\Users\Saftsnubben\Desktop\Buckets\Test'...

m.AllocationBase 0x9F0000, m.BaseAddress 0x9F0000, m.RegionSize 0x4000, m.State 0x1000

C:\Users\Saftsnubben\AppData\Local\Atlassian\SourceTree\git_local\bin\sh.exe: *** Couldn't reserve space for cygwin's heap (0x9F0000 <0xA00000>) in child, Win32 error 0

      0 [main] sh 11288 sync_with_child: child 11836(0x100) died before initialization with status code 0x1
     11 [main] sh 11288 sync_with_child: *** child state waiting for longjmp
C:\Users\Saftsnubben\AppData\Local\Atlassian\SourceTree\git_local/libexec/git-core\git-submodule: fork: Resource temporarily unavailable



Completed with errors, see above.

Regards

Anders

4 answers

1 accepted

0 votes
Answer accepted
Anders Hvid Nov 13, 2013

Nevermind, somehow solved it by reinstalling sourcetree.

9 votes
TheC Jul 22, 2016

Even if the Question is old.
Update the embedded Git-Version via

Tools => Options => Git => Update embedded Git

helps.

Erik Tainio Lagusson Sep 29, 2016

This saved my bacon! Everyone of the other solutions I found did nothing.

Fabio Cappellino Dec 02, 2016

Yeah, I started see this sh.exe.stackdump in every folder, updating embedded Git solved this.

Thanks!

Padam Bhandari Apr 06, 2017

Tried re-booting, re-installing source tree did not help.  But updating the embedded Git did it. You saved my day 

0 votes
David Shaskin Dec 17, 2014

I recently ran into this, and I was able to determine that Removing or Deleting the sh.exe.stackdump file causes this error. 

So far, the only solution I can find is  

1) Uninstalling SourceTree and anything to do with Git.

2) Restarting the computer

3) Re-installing everything you unistalled

Chris Branch Apr 06, 2017

This is the only solution that worked for me; thanks.

0 votes
Rod Barnes Oct 05, 2018

Adding another solution:  I downloaded Git directly (2.19.1) and then in SourceTree switched from [Embedded] to [System].  This worked for me.

Why? Because I tried the [Update Embedded] option (twice) and it wouldn't finish.  Or, rather, it finished (no errors) but did not change the version of the embedded Git despite restarting SourceTree.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

359 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you