Sourcetree asks to configure remote settings on every pull request

Almost every time I make a pull request, I get message "you don't have any remotes which have extended integration settings configured, you need to edit your remotes to add details such as the hosting type and base URL. Click the settings button to open your remote list."

When I open settings, everything is correct. If I click edit, then I don't edit anything and click ok, after that pull request works. If I make another pull request right after that, it works, but if I wait for example one day, then it asks to configure again.

8 answers

This widget could not be displayed.
Mike Corsaro Atlassian Team Feb 15, 2018

Hello! This has been a tough one to debug on our end. To attempt to address the issue, we've made a change that will be rolled out in the 2.5 release. Hopefully this will solve it. Please follow this issue for progress.

Thanks, @Mike Corsaro.  I appreciate the info.  It's nice to know that you're aware.  If I can provide any of my system info -- within security reasoning, of course -- just ask.

This widget could not be displayed.
Mike Corsaro Atlassian Team Aug 22, 2017

Hello! Which version of Sourcetree are you running, and on which OS? Thanks!

Windows, version 2.1.10.0.

Mike Corsaro Atlassian Team Aug 23, 2017

Is the extended integration with stash, bitbucket, or github?

I was hoping someone would have solved this because the same thing has been happening to me with the extended integration options for Stash.  Version 2.3.1.0.  Although it's not quite every pull request.  It will hold for a while but reset itself eventually.  It's not updating the config files when I save the changes even though I'm running it as admin, and so I wonder if that's the problem.  I have uninstalled and reinstalled.  Does anyone know the format to manually update the config file for Stash extended options?

This widget could not be displayed.
Yup, I'm getting the same thing for my company's on-prem stash server. I have to set the `host type` and `host root url` everytime I restart the program on every single repo.
This widget could not be displayed.

Same issue for me: I have to set up Stash integration settings nearly every reboot. Though sometimes it disappears before reboot or is kept after reboot.

Tried update (several versions released since issues first appeared), complete reinstall, `sourcetreeconfig` removal. Nothing helped.

Issue still persists

This widget could not be displayed.

Same thing here, Windows 10, SourceTree 2.3.5.0

This widget could not be displayed.

Same here - been happening for quite some time across numerous SourceTree updates - including 2.4.8. Windows 10. 

This widget could not be displayed.

Same here, it will happen on every new branch. When I have openend the settings menu, it will not be asked again for that branch.

Windows 10 - SourceTree 2.4.8.0

This widget could not be displayed.

Solved on Windows.

Make sure that the URL of your remote is the https:// one. Not the SSH compatible one.

Sample URLs for the Remote feature:

  • GOOD URL: https://YOU_USERNAME@bitbucket.org/YOU_ACCOUNT/YOUR_REPO.git
  • BAD URL:  git@bitbucket.org:YOU_ACCOUNT/YOUR_REPO.git

Don't try to build it from this example URL. A safe bet is to simple go on Bitbucket.org, then click the clone button and switch the connection type from SSH to HTTPS and finally copy the URL.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

871 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you