Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree always asks my ssh passphrase

I work on some projects hosted on gitlab.com and I'm using ssh to connect to these repositories. In SourceTree, I checked the option to save my ssh passphrase, but at ever action I take, a popup asks for it again... That's very irritating!

How can I save the passphrase manually for that account

Note that the passphrase is saved for a project hosted on a custom gitlab installation though...

2 answers

1 vote
bgannin Atlassian Team Nov 06, 2017

What OS platform and what version of Sourcetree are you using?

I'm on macOS High Sierra (Version: 10.13.2 Beta (17C60c)) an I'm using SourceTree 2.6.3 (134).

@bgannin

Do you have any idea what this is caused by and how to fix it? It really bothers me!

Manju Atlassian Team Nov 20, 2017

Can you please check if the ssh keys are loaded to the agent? You can do so by running below command on a terminal window.

ssh-add -l

It should list down the keys added to the agent. If you don't find anything listed, please add the key to the agent with the command below,

ssh-add <path_to_key>
Like sudara_fernando likes this

That was indeed empty, I now added my ssh key and guess what, it works. Thank you very much!

I have the same issue but in Windows 10. ssh-add from command-line doesn't seem to work right. (Error connecting to agent: No such file or directory) Regardless, what would address the root cause? What can be set or done from the sourcetree application to remedy this?

I have the same problem.  Tried setting up ssh-agent as a service using PowerShell, but does not make any difference.

Had the same problem. I had to convert the .ppk key-file to openssh file-format and then I fed that file into ssh-add. It worked and I think it achieves the desired result but I'm not quite sure. Will keep an eye on this thing over the next few days.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,336 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you