It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree 'Working Copy' view stuck showing one file in diff mode

After updating SourceTree to 1.9, I did something that causes my 'Working Copy' view to always display only a single file in diff mode. I can find no way to get it back to showing me my list of files. If I select to display 'pending', I see one pending file in diff mode. If I select all, I see one (different) file from among all the files.

I've tried refresh, reinstalling, and cloning a new project from bitbucket -- no change.

I even tried reverting to 1.8.1 -- same behavior with older diff view, then upgrading to 1.9 again. Nothing helps.

1 answer

1 accepted

5 votes
Answer accepted

Hey John,

Looks like you hit a bug which causes your view to be remembered like that. This has been fixed now, but if your preferences are set like that then it'll stick around regardless of what version you install. To fix this, on the left of that pane there's a border which is twice as thick as other borders. This is because it's two borders stuck together (both are splitters that can be adjusted). You can reveal that view again by grabbing the right hand one, which is quite difficult as they're 1px wide, but it is do-able. Grab the right hand splitter line and drag it to the right to reveal the missing view.

Hopefully that makes sense, but if not, feel free to question the problem again.

Cheers

That did the trick. Thanks so much for the answer. Going without for a couple of days made me reallize how much I use and appreciate SourceTree.

I just ran into this issue with 2.0.3 -- thanks so much for the answer, this worked perfectly. A suggestion for the Atlassian folk is make it so that this middle-windows cannot be collapsed completely -- I can't imagine any use-case where you'd want to completely hide it anyways.

Been suffering through this for months! Putting it into "Tree View" would at least show all files/changes, but they were totally unnavigable. Thanks much!

Agreed - this fixed things for me. Having an update that just bumped up the minimum width in a user's preferences would be nice, but glad I found this.

It saved my day!!

Thanks a lot, I tried different views and thought it's a bug. It should be more obvious that it was hidden

I just ran into this now on version 3.1.1 (213). Thanks for the answer! It was really confusing to only see one file.

The answer is a little confusing though saying that it has been fixed. It looks like the problem has been there for over five years now. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,910 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you