It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree Windows 404 on Create Pull Request on the Web

When committing any work to any repo I stage my changes, do not check "push changes immediately to origin/branch", select "Create Pull Request", type my comments, then click 'Commit'. Every time it 404's and pushes my commit to the remote. What gives?

404.PNG

Things I've done: refreshed OAuth token, deleted and re-cloned repos, restarted

2 answers

0 votes
Mike Corsaro Atlassian Team Nov 19, 2018

Hello! Could you check which version you're on (Help > About)? There was a bug where we accidentally added an extra '\' at the end of 'bitbucket.org' when making a PR that was recently fixed. Thanks!

I'm running version 3.0.8.2279

Any word on this?

Auth fail, even though my OAuth token was valid. I tried refreshing the token and trying again - same result.new-sourcetree.PNG

Mike Corsaro Atlassian Team Nov 26, 2018

This is probably an issue with the git-credential-manager. Try downloading v1.18.3 here which should fix it.

That fixed the new auth error. I'm still getting a 404 with automatic commit when I create a PR and do not check commit changes. Still two /'s after bitbucket.org in the URL.

sourcetree-is-a-POS.PNG

Mike Corsaro Atlassian Team Nov 26, 2018
  1. Open the repository
  2. Click "Settings" in the main toolbar with the gear icon
  3. Double-click/edit the "origin" item
  4. Check the "URL / Path" and post that here
  5. Optional: change the "Remote Account" to use the Bitbucket account you added previously.

https://steveg-iotashome@bitbucket.org/iotashomedev/ec2-deployment.git

remote.PNG

Mike Corsaro Atlassian Team Nov 27, 2018

Okay, so there's nothing wrong with the URL. Could you open the file "you repository/.git/sourcetreeconfig.json" and check the value "BaseUrl" under "RemoteProjectLinks" and ensure there isn't an '/' at the end?

Yes, all of my repos have "BaseUrl": "https://bitbucket.org/" in their sourcetreeconfig.json files.

config.PNG

So I removed the / after .org, saved the file, opened sourcetree, made some changes to a file in the repo, staged changes, selected create PR, and it brought me to the PR creation page over HTTPS, but my changes were already committed to the repo (I did NOT check push changes to origin). So we're halfway there.

Any more ideas or should I run away from this tire fire?

Mike Corsaro Atlassian Team Nov 29, 2018

Are you sure you didn't push to the repository? We haven't seen any other users seeing a push happen when a the PR link was opened. Did you check the commit log in Bitbucket to see when that commit was actually pushed?

100% sure.

The PR link opened and allowed me to type in comments, but wouldn't let me commit because there were no changes - they were committed a few seconds earlier.

Mike Corsaro Atlassian Team Nov 29, 2018

Ah okay. Just a FYI:

pr.PNG

Yep, my client has the same message.

So maybe I'm missing something here. I just went through the same process of staging a file, writing a commit message, and creating a pull request through the GUI.

PR-test.PNGSo what is the point of the "Push changes immediately" box if it is ignored and always pushed? Also, how am I supposed to make a pull request if there are no changes?
PR-test2.PNGOr is this behavior due to the fact that I'm working on/updating master and not merging a remote branch INTO master?

Mike Corsaro Atlassian Team Nov 30, 2018

I see -- I thought you were using the context menu pull-request feature (right click on the branch in the sidebar).

 

The "Push changes immediately" box exists so you can push automatically after commiting (if you had "Create Pull Request" unchecked).

 

Working on master and merging into master won't do anything because they're the same branch.

Okay Mike, I'm on the same page now - thank you for your help!

Is there an open bug report for this?

The app continuously rewrites the trailing slash to the "BaseUrl" string value "https://bitbucket.org/" inside the sourcetreeconfig.json file which forces me to check/edit the file before I want to create a PR in each of the repos I work in.

Mike Corsaro Atlassian Team Dec 03, 2018

Yeah -- the fix was back-ported and will be fixed in the next release (3.0.11) which should be released sometime tomorrow if everything works out 🙂

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you