Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree Proxy Configuration - HTTP 407 Error Edited

I am attempting to configure Sourcetree from behind my proxy. I am using v 2.5.5.0

I am getting:

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false ls-remote https://<<repo>>
Output:
Error: fatal: unable to access 'https://<<repo>>': Received HTTP code 407 from proxy after CONNECT

 

Note, I have configured the proxy settings in Options > Network. I have also entered the username and password.

Capture.PNG

 

I am using the system GIT.

I can run the clone successfully from the command line when I set the proxy via:

 git config --global http.proxy http://<<username>>:<<password>>@<<server>>:9090

I also believe that Sourcetree is not setting the username/password correctly, as when I run 

git config --global --get http.proxy

I get:

http://10.83.75.3:9090 

Note, the username and password details are not included.

Can you advise how I should configure my proxy from Sourcetree?

Thanks

1 answer

0 votes
Mike Corsaro Atlassian Team Jun 14, 2018

Hello! I can confirm this is an issue in the latest builds. I'll file a ticket internally for it. As a work-around you can use the git config command to set the proxy -- just uncheck the "add proxy server config to git" before running it.

Thanks Mike. Can you confirm back when there is an ETA for a new build which fixes this bug?

Was there ever a fix for this ? In the latest builds of sourcetree, there is not even an option to set proxy details

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,289 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you