Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree Login Edited

Ciao

After upgrading to sourcetree 2.6.10 I had to renew my credentials.

Therefore (following the result of other threats) I used the Atlassian account to login, resettet the password and my credentials are valid and I'm able to enter My Atlassian Webppage & Account.

But I I use that credentials (mailadress & password) on the sourcetree login I always get:
" Log in to continue - Log in with Atlassian account Something went wrong while attempting to validate your credentials."

Can somebody expalin wwhat I have to change/correct that I'm able to use sourcetree again...?

Thanks all for your support!

Kind regards

Michi from Vienna

Remarks: I'm using Windows 10 client for sourcetree

2 answers

0 votes
Ana Retamal Atlassian Team Sep 04, 2018

Hi Michi, welcome to the Community!

Is Internet Explorer updated to the latest version? Sourcetree relies on it for authentication and might throw errors if it's not the latest.

If you're in the latest IE and still unable to log in, please let us know so we can continue helping you!

Kind regards,

Ana

Ciao Ana,

 

Thanks for quick reply:

Usually I use the latest version of Firefox :)

But related Internet Explorer I has installed IE11.228.17134.0 (Update Version 11.0.80)

Is that fine or do I have to upgrade something?

Ana Retamal Atlassian Team Sep 05, 2018

Hi Michael, that should be fine.

Are you still having issues to log in? If so, can you check the log? In Windows it's located at C:\Users\<username>\AppData\Local\Atlassian\SourceTree\sourcetree.log

Can you also send us a screenshot of the error message you get?

Cheers!

Ana

Still the same :(

I resetted again the password to ensure using the correct one...

Afterwards using my credentials (mail & new password) after selecting to use Atlassian account and get again

Log in to continue - Log in with Atlassian account Something went wrong while attempting to validate your credentials.

The logfile shows

....

ERROR [2018-09-03 19:34:23,213] [1] [SourceTree.Analytics.Crash.BugSplat.CrashAnalyticsService] [DispatcherUnhandledExceptionHandler] - DispatcherUnhandledExceptionHandler for [Sourcetree, 2.6.10.0] called with [System.Windows.Threading.Dispatcher, System.Windows.Threading.DispatcherUnhandledExceptionEventArgs]
System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei SourceTree.ViewModel.RepositoryTabContainerViewModel.SaveOpenTabs()
   bei SourceTree.AppRoot.OnExit(ExitEventArgs e)
   bei SourceTree.App.OnExit(ExitEventArgs e)
   bei System.Windows.Application.DoShutdown()
   bei System.Windows.Application.ShutdownImpl()
   bei System.Windows.Application.ShutdownCallback(Object arg)
   bei System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   bei System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
ERROR [2018-09-05 10:50:38,442] [1] [SourceTree.Accounts.DefaultAccountPersistenceService] [LoadFromFile] - Unable to deserialize accounts from [C:\Users\home\AppData\Local\Atlassian\SourceTree\accounts.json] defaulting to empty and backing up file
Newtonsoft.Json.JsonSerializationException: Unexpected end when deserializing array. Path '[0]', line 35, position 3.
   bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ThrowUnexpectedEndException(JsonReader reader, JsonContract contract, Object currentObject, String message)
   bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateList(IList list, JsonReader reader, JsonArrayContract contract, JsonProperty containerProperty, String id)
   bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateList(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, Object existingValue, String id)
   bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
   bei Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
   bei SourceTree.Accounts.DefaultAccountPersistenceService.LoadFromFile(String filePath, JsonSerializer jsonSerializer)

What to do?

 

Thanks
Michi

Btw. I tried to reinstall the old version the day before yesterday and had issues too, therefore now I deinbstalled again the old one and downloaded and installed the new version 2.6.10

I got an Crash Report after Closing the Login-Page & Sourcetree too....

Tried to reinstall new - Still same issue :(

Atlassian_Login.PNG


As requested the screenshot - My login data should be known by Atlassian only :o)
Thanks for any helpMichi

Any hints for me...   Login still not working :(

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,252 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you