Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,361,135
Community Members
 
Community Events
168
Community Groups

Sourcetree Git Flow not Supported

Hello, 

We have been using Git-flow for a while. On some projects it seems to work fine, But on most projects I can't use Git-flow.

Every time I press the Git-flow Button I get the following Error Message:

Git-flow not supported.
You'll need to upgrade to Git 2.6.4 or later. 
We recommend upgrading to Git 2.24.1.2

 

When I use Git-flow via command line everything works as expected.

 

I am using Embedded Git with Version 2.24.1 

My Sourcetree Version is 3.3.8.3848


I tried everything that I've found in here so far, but nothing worked. 

2 answers

Using source tree 3.4.8 and 3.4.9 (Windows 11 )  i'm getting this error, tried uncheck/embedded/check all possible fixes but nothing , i have git version 2.35.1 and embedded git 2.36.0 and i can't use Git-Flow!

After selecting checkbox "Tools/Options/Git/Git Version/Disable LibGit2 integration" the error message does not appear any more for "Git-flow/Start New Hotfix" action in my case.

(Win/System Git version 2.16.1/Sourcetree 3.3.9.3870)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

79,105 views 135 29
Read article

Atlassian Community Events