Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,444
Community Members
 
Community Events
165
Community Groups

Sourcetree / Bitbucket Registration Issues

I am attempting to open Sourcetree. I have yet to get past the registration part of the install. I have a created two bitbucket accounts so far. I am having an issue where I open sourcetree and in have to register a Bitbucket Server or Bitbucket account. If I click on the Bitbucket account, it opens a web browser and allows me to "Grant Access". Once I click this it re-directs me to "localhost:#####/?state=authenticated&code=###". At the same time, the sourcetree app changes from "waiting for authorization" to the previous page of selecting bitbucket server or bitbucket. The registration is somehow getting hung up. 

If I go to the BitBucket account and look into the Settings>ACCESS MANAGEMENT>OAuth>OAuth integrated applications, it tells me that I have "Sourcetree for Windows" granted as accessible. It also allows me to revoke this permission and I have tried countless ways of retrying this authorization by revoking and reapplying it. 

 

So I am left here with Sourcetree saying I havent registered, even though both of my Bitbuckets have shown me that I have. 

I have tried deleting and redownloading every program involved, I have done updates to other apps hoping it would work. Not sure what to do next here.

 

1 answer

Addition: Every once in a while, it will re-direct me to an "Access granted" page and says I can now close that webpage and continue, however the sourcetree app doesnt allow me to move forward.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,964 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you