Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree 2.x memory hog?

Before the security alert for < 2.x versions came in, I had installed 2.x and found it to be almost unusable as it was eating all of my RAM (> 3 GB). Then I reverted back to version 1.9.

Now after the security alert, I tried installing version 2.x again.it went well last week. today again it is behaving strangely. Took up 3 GB and the application was all hung. Restarted my PC and again it is the same. It is unusable.

 

Should I revert back to 1.9 again??

 

sourcetree_memory.jpg

9 answers

1 accepted

9 votes
Answer accepted

SOLUTION.

I finally found the issue that was causing my memory problems with it taking up all the RAM and CPU usage.

SourceTree added my c:/user/{username} folder as a repository.  This folder includes a large amount of GBs worth of data, and also includes other Git repos nested within the folder structure.  Every time SourceTree starts up, it begins to scan every single file in this folder and the subfolders which takes forever since it runs through GBs of comparing.  

I was able to follow this and get rid of that repo with the addition of deleting the .git and .sourctree files in the folder itself,

https://jira.atlassian.com/browse/SRCTREEWIN-6860

Thanks Ben. Your suggested solution is working, I tried it and my issue was resolved.

Nice one Ben, exactly my issue also! Just deleted the ".git" folder

Worked like a charm mate. Thanks!

Thanks Ben! That was exactly the problem I was experiencing also.

Perfect!
I have to login to vote for you.
Thanks Ben!

thanx a lot bro

You make my day! Thanks! :D

I'm getting the exact thing.  Crashed my computer once it got up to 8.5 GB.  Between this and nothing updating in it, the app is unusable and worthless.  I reverted back to 1.10.  Though, now it prompts me after I open to update to 2.0 so I think I'll revert to 1.9.

Seriously, 2.x is the worst update I've seen on this app.

On my Windows 7 it's cosuming upwards of 10GB work or Memory and at time 80% of the CPU

So I'm having to close SourceTree, work on what I need to do and then re-open SourceTree to commit my changes

Really needs to be fixed

I am getting pretty much the same thing. SourceTree starts out using about 40 Mb then climbs up to about 5.5 Gb. It then fluctuates between 2 Gb and 7 Gb. A coworker with a similar setup is running at about 82 Mb. So far I haven't noticed any obvious difference in our configurations.

I also noticed that after the update to 2.0.20.1 on Windows 7, I have to Run as Administrator. Otherwise I get a dialog indicating that "...SourceTree\Update.exe - This program is blocked by group policy."

Same story here. Using SourceTree 2.7.1 on Mac OS X and it crashes constantly and uses up more CPU than Photoshop (which requires the GPU). Highly suggest reviewing and reworking performance for your next release.

Is Atlassian working on this issue? I'm using 2.6.x and it's the same thing. I can't even try to remove the repository for the suggested fix for windows 10 because on my machine it's sucking up 15G of memory. It's unusable on my new Mac too. At time it consumes 4-6G of my available 8G of memory on my Mac. This should be a high priority issue IMHO.

Same experience on Windows 7.

Hmm... I've been using command line for the past two days as source tree is unusable. Will uninstall 2.x and install 1.9 again until atlasssian team comes up with a resolution.

 

As David Finegan mentioned, it is not in all computers. Some of my team mates are running 2.x without any problems. 

Mine is a windows 10 machine. I didnt get the "Run as Administrator" issue.

Can I add my voice to this as well? SourceTree 2.0.20.1 is unusable, it runs away with CPU and memory usage.Stability is more important than features, and this is something to keep in mind when updating SourceTree (and everything else in the software world). 

For the record, my machine is Windows 10. 

Cheers

Pete

Getting the same thing over here.  My company required everyone to update to 2.x because of a security issue with 1.9x.  However, no I can barely get anything done because SourceTree seems to freeze and take over all the memory.

I'm able to do Git through the cmd line without any problems so I know for sure it's not some issue with my Git.

Other co-workers don't have the same memory problem as me.  Nearly all of us are using Windows 7 (such as me) and some are using 8.

Same CPU issues here from sourcetree 2.x - at first i thought it was Windows Defender fighting with it, but after disable of that, sourcetree was stil maxing my CPU and freezing up the entire OS consequently.

 

I've reverted to doing all git work via cmd line until a fix is put in place.

Very true... i have also started using more command line than before!

Wondering if atlassian is planning to provide any fix.

Same issue here! it consumes around 5 GB and takes around 80% of CPU usage. All of this started comming after I restarted my PC but before it was OK.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,253 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you