It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree wont start or install

This has caused me hours of pain and work time lost!

My SourceTree just suddenly wouldnt start today, i had been using it fine for many months now. 

I've looked online and tried all the various suggestions but nothing works.

Ive tried uninstalling the app, reinstalling all different versions from the latest 2.4.8 to older versions. Ive also deleted the SourceTree folder and the Atlassian folders. Ive tried using CCleaner to uninstall and also to clean registrys. 

However, anytime i uninstall and try to use the installer i get a blue splash screen with sourcetree logo come up for a few seconds only, then the app is suddenly installed again and the folders are back where i deleted them from, however the app still does not open.

When i run the installer, its like its not even installing it, just bringing back the deleted folders from the dead, even though ive emptied out the recycle bin etc..

Please if you can help me fix this terrible issue so that i can open it up again?!

Im on the latest version of windows 10.

Thanks.

2 answers

1 accepted

0 votes
Answer accepted

I finally managed to sort it out, by downloading the newest version of SourceTree 2.5.5.0

 

All sorted now, no thanks to the useless team at Atlassian!!!

0 votes
Ana Retamal Atlassian Team Mar 13, 2018

Hi Nadim! Can you try a clean install and see if the issue gets fixed? You can do that following the steps:

  1. Wipe Sourcetree preferences.
  2. Uninstall Sourcetree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step:
    • Navigate to C:\Users\<UserName>\AppData\Local and delete Sourcetree & Sourcetree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all Sourcetree Files/ folder.
  4. Download SourceTree and install it.

If that still fails, can you check if there's some more info in the logs and post it here? The logs can be found at

C:\Users\<username>\AppData\Local\Atlassian\SourceTree\sourcetree.log
Note that the AppData folder is hidden by default on Windows Explorer.

Kind regards!

Ana 

Hi Ana,

I tried the above that you recommended but still same issue :( 

After uninstall whenever i go to install again, it doesnt run the install wizard, instead it just brings up the blue sourcetree image logo and then suddenly places the folders back where i just deleted them manually from!!! 

 

I looked at the LOG file and here is what it says:

 

ERROR [2018-03-14 21:05:00,950] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2018-03-14 21:07:45,755] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied

Any help please?

Ana Retamal Atlassian Team Mar 19, 2018

Hi Nadim, thanks for posting that error. Please navigate to the config file location

C:\Users\{USERNAME}\AppData\Local\Atlassian\SourceTree.exe_{RANDOM_GUID}\2.3.1.0\user.config 

and find the following line:

<setting name="AutomaticallyCleanUpDictionaryFiles" serializeAs="String">

   <value>True</value>

</setting>

Make sure that value is set to True

Let us know if it worked for you!

Kind regards,

Ana

Hi Ana,

I checked the user config file you mentioned above, but it doesnt contain the line you said im afraid :(

This is all that file contains:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<userSettings>
<SourceTree.Properties.Settings>
<setting name="NPSAnonUId" serializeAs="String">
<value>d57bedd4-6572-468f-9d0f-23f1bcf56054</value>
</setting>
</SourceTree.Properties.Settings>
</userSettings>
</configuration>

Hi Ana,

 

its been over a month now and im still awaiting a response from your team to help solve this problem! 

 

Are you going to bother helping at all or have you given up?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you