Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


SourceTree won't run

I'm trying to install SourceTree 3.4.15 on a windows 32-bit VM. This VM has had SourceTree installed previously and it (usually) worked fine. However each time I try to start the application it opens for a couple of seconds and then stops, with no error message.

I've tried uninstalling and deleting C:\Users\<user>\AppData\Local\Atlassian and C:\Users\<user>\AppData\Local\SourceTree. Then I removed all credentials that seem to have anything to do with atlassian using the Windows Credentials Manager. I disconnected the VM from the internet then I rebooted and tried reinstalling. No joy.

I've done lots of permutations of these actions: with and without internet, deleting only the cache files etc etc. Nothing has fixed the problem.

I looked in C:\Users\user<>\AppData\Local\Atlassian\SourceTree\sourcetree.log and there are a couple of errors, here's the whole log:

2023-11-06T17:00:04: LogHost: Initializing to normal mode
ERROR [2023-11-06 17:00:25,012] [1] [SourceTree.Notifications.NotificationsManager] [Log] - Unable to set owner as parent is not visible or non-existent
ERROR [2023-11-06 17:00:27,294] [1] [SourceTree.App] [Log] - Failed to start
System.ComponentModel.Win32Exception (0x80004005): The specified executable is not a valid application for this OS platform.
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(String fileName)
at SourceTree.Security.PageantSshKeyAgent.Launch(Boolean promptForKeyIfBlank, String keyfile)
at SourceTree.Security.DefaultSshKeyManager.LaunchSshAgent(Boolean promptForKeyIfBlank, String keyfile)
at SourceTree.Security.DefaultSshKeyManager.LaunchSshAgent(Boolean promptForKeyIfBlank)
at SourceTree.AppRoot.OnboardIfRequired()
at SourceTree.AppRoot.<OnStartup>d__24.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.GetResult()
at SourceTree.App.<OnStartup>d__9.MoveNext()

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events