Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,219
Community Members
 
Community Events
176
Community Groups

SourceTree won't open after minimise

Since updating to 3.0.5, whenever I minimise the SourceTree window I cannot open it again and I get the angry Windows DING noise. I have to right click it in the task bar, close it, then reopen and it's fine. Anybody else seeing this behavior? I'm using it on Windows 7.

17 answers

1 accepted

5 votes
Answer accepted
minnsey Atlassian Team Nov 19, 2018

Sourcetree for Windows 3.0.9 which contains a fix is being rolled out.

You can download it directly from http://product-downloads.atlassian.com/software/sourcetree/windows/ga/SourceTreeSetup-3.0.9.exe

Hi Michael,

You might know this already, however, when I click "check for update" the dialog shown in the screen shot below pops up.


Cheers, Chris

Screenshot (49).png

Like Carlos Saldarriaga likes this

But the good news is that downloading the installation file you linked to and installing it has fixed this issue, thank you!!

Works for me! :)

just got the update notification and updated to 3.0.9, but unfortunately the problem still persists for me.

I now have 3.0.9 and it's fixed for me...mostly.  When clicking the minimize button in the upper right (app is maximized), and then clicking the icon on the taskbar, it activates the icon, but doesn't show the window unless I click a second time.  It is only an annoyance at this point, so thank you for fixing the biggest part of the issue.

Okay, I noticed that it seems to only occur in the way I described above when minimization means that only the desktop is showing (no other windows).  When other windows are behind the SourceTree window, then minimizing the SourceTree window properly re-activates upon clicking the icon.  Or it occurs if minimizing SourceTree using the minimize button and then minimizing all other windows such that only the desktop shows.  It has something to do with having no other windows on the desktop.

Thanks, This Solution worked for me.

Thanks, it worked.

This issue is also occurring for me on windows 10

I have a minor work around for this.

Left click on sourcetree in the taskbar and then press enter.

 

Also avoid using minimise arrow/keyboard shortcuts just click on the icon in the tray to minimise/maximise which seems to work fine for me, for now.

Deleted user Oct 17, 2018

Good workaround. I'm also using Windows 10 and have the same issue.

After minimizing SourceTree with the _ icon in the upper right I receive a ding when trying to click on it in the taskbar .

Clicking it and then using Windows+Up or Windows+Down will bring it back, or the method you described: Windows+Enter.

Thank you for the workaround, works fine!

Like Edgar Silchenko likes this

double left mouse click also works for me

Also worth keeping in mind pressing Enter will actually send the enter key to the program.

A better solution would be to click on the icon then press [windows logo key] + [up]

Thanks for workaround!

I just upgraded to 3.0.8 and it still has this problem.

I confirm, Still the same problem in version 3.0.8.

I also confirm. I upgraded to version 3.0.8 on windows 7 pro.  Still the same problem.

Same problem with latets 3.0.8 update, 2 screens.

Experiencing the same issue on two different systems (Dell deskop & Lenovo Laptop). It is working okay inside Citrix desktop for me though.

Windows 10 - 3.0.17 and it still fails.

edit: seems Choco isn’t correctly updating the ST package. Will try again with manual install and see if the problem recurs.

Why are you on 3.0.17 and complaining?  The latest is 3.1.3

Like Scott likes this

This is still an issue in 3.0.17.

1. On a laptop without external monitor it happens only after one click on the taskbar icon, second click (usually) brings SourceTree  window.

2. On a desktop with two monitors it's getting worse - before at least after multiple clicks on the taskbar icon SourceTree  window could appear.  Lately it doesn't work at all.

@"Jacob H" Thank you for a workaround - clicking Windows button + Up button works!

 

BTW, status of this issue shouldn't be SOLVED - because it's not solved!

minnsey Atlassian Team May 07, 2019

Can you try upgrading to 3.1.2 or above?

3.1.2 has some nasty bug(s) of disappearing bookmarked repositories when opening a new tab and clicking around. I'm staying away from it for now and downgraded back to 3.0.x...

I didn't realise there's an update. I'll try and report.

[EDIT] Updated, actually twice - 3.1.2 then to 3.1.3. 

So far so good.

SourceTree 3.1.2 fixes the problem for me (Windows 7 64bit).

minnsey Atlassian Team Mar 20, 2019

Thanks for the feedback

This is still an issue in 3.0.17.

I only have it when working on a remote desktop session using Windows 7

minnsey Atlassian Team Feb 07, 2019

Hi

Thanks for the extra detail. To be honest that is not a scenario that test consistently.

Using 3.0.12. Still take time to restore the window.
I had to click for a couple times then the window will show up. :(
Getting angry when this happen when i need sourcetree urgent.
minnsey Atlassian Team Jan 09, 2019

Thanks for the feedback. We do try to test in as many combinations as possible and it does work in our environments but we will continue to investigate.

Fixed for me, using dual monitors and 3.0.12 :D

I upgraded to 3.0.12.2543 and it stills seems to be happening

Same here. This bug still occurs for me (using v3.0.12.2543, Dual monitor, both 1920x1080, on Windows 7 as well as on Windows 10)

minnsey Atlassian Team Jan 09, 2019

Thanks for the feedback. We do try to test in as many combinations as possible and it does work in our environments but we will continue to investigate.

0 votes
minnsey Atlassian Team Nov 07, 2018

Hi

A fix for this is just being released to beta testing and should be available to all users soon.

Great news, FYI, I also have the same issue on a single monitor setup ( Wide screen 3440 x 1440 ) so am looking forward to this being fixed!

Works for me.

The problem still occurs. 

Version 3.0.9, Windows 10 Pro, dual monitors using rdp (remote machine has issue)

 

Seems to be reproducible by using "Show desktop" -> all minimise, click SourceTree -> it makes a sound -> nothing happens (still minimised, enter works)

Yet another "happens to me".  This happens whether or not there are multiple displays.  It is simply triggered by minimizing using the upper-right minimize button and then attempting to click the icon in the taskbar.  Should be rather simple to reproduce.  I am on Windows 10 build 1803 presently.

Can also confirm the workaround above works.

Seeing this on v3.0.8. I have a Lenovo Y50 laptop + external monitor. It happens both on laptop only and laptop + external monitor, so it is not unique to dual monitors. The current workaround I'm using is clicking on the taskbar icon and hitting Enter to bring the screen back up.

Created a jira for this here: https://jira.atlassian.com/browse/SRCTREEWIN-10755.

Had to downgrade from 3.0.8 back to 2.6.10.0 and the issue when away.

I have this and yes "bring to front" from the task manager does work.

I have the same problem. Windows 7 Enterprise 64bit, first monitor 1280 * 1024, second 1680 * 1050. I found a way to run Sourcetree after minimizing the application. This is possible using the task manager.

This also works for me.

0 votes
minnsey Atlassian Team Oct 08, 2018

Hi

Thanks for reporting this. We have seen a handful of similar reports and are investigating though currently we can't reproduce it.

Can you provide any more details that might be relevant? e.g. are you using multiple monitors, especially hi-definition settings etc?

I have the same exact issue, except I am running Windows 10. I am using two 1080p monitors.

I am running dual screens. 1x DisplayPort (2560*1440) and 1x DVI (1920*1080). Graphics card is an NVIDIA Quadro K4000 if it's relevant.

I can only produce it when I minimise the window using logo+down or the minimise button.

If i keep clicking the icon on the taskbar it will minimise/maximise without much issue (sometimes it doesn't minimise/restore so I have to press it again)

I'm also running into this on Windows 10. Two 1080p monitors and a Radeon RX 460

I have the same issue. Windows 10, Lenovo y50-70, Dual monitors (different DPI). I have to close and reopen every time I minimize. I tried the workaround with "Bring to front" in task manager, and it works"

Same issue both locally and over RDP. Dual monitors 2560x1440 same DPI

Workarounds work.

Can I suggest the team try use standard windows controls for the application? Custom might look nice but it causes untold issues with remoting/windowing software.

I can also reproduce the issue when using the "_" minimise button or the Windows Key + down arrow. Minimising by clicking the taskbar icon does not.

Running 2x identical 1080p monitors, Windows 10.

Sometimes after minimising the window with the "_" button, spam-clicking the icon in the taskbar can reopen it. Otherwise, the workarounds of clicking the taskbar icon + enter or Windows Key + up arrow work.

Same problem here. 2x1080p and 1x1440p. All screens with a UI scale of 125%. It works if I spam the taskbar button for a couple of seconds.

I have a similar Problem.

To reproduce it:

1. Minimize Sourcetree

2. Put Windows 10 into sleep mode

3. Wake it up again

Then the Sourcetree window can't be restored

I have the same issue. Click the minimize button in the top right corner, maximizing from task bar does not work. The workaround described above works.

I'm running Win10, ST 3.0.8, single 1080p monitor.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events