Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree won't launch external diff

Deleted user Jul 25, 2013

I've used SourceTree in the past to look at diffs with the 'external diff' tool. I was using FileMerge but recently this stopped working. I then followed the instructions to get TextWrangler and KDiff3 installed. Neither of these will launch when I hit the 'External Diff' button. ALthough the configuration will accept me selecting them as my diff tool.

I'm using SourceTree 1.5.6 which the App Store says is the latest version.

3 answers

go to tools git and set it to embedded git and MAKE SURE IT'S UPDATED! Updating it fixed the problem for me!

Worked for me too!

Hi Rafeek,

Just as a quick note, we no longer publish to the App Store due to sandboxing restrictions. The current version is available from www.sourcetreeapp.com which is 1.6.2.

The problem you're experiencing usually happens because SourceTree looks in some pre-specified paths for the application you've stated and can't seem to find it. Do you know what location KDiff3 currently is? If you could tell us that then we could narrow it down to what the problem could be.

Many thanks in advance.

Deleted user Jul 29, 2013

It's installed as an app package in /Applications, the path to the executable is /Applications/kdiff3.app/Contents/MacOS/kdiff3

I can launch it successfully by either running it from a Terminal window using that path or by launching it from Finder using the app icon in /Applications

This should work absolutely fine. I've just tested this myself with the same path for kdiff3. The only thing I can think of is that you have some other kdiff3 path that's being picked up which is invalid. Could you run the following at the terminal and copy/paste the output?

locate *kdiff3

This will just find all occurrences of files ending in 'kdiff3' which is the executable. One other thing to try quickly is going into SourceTree, changing the diff tool to something else and closing the preferences pane, then opening it back up again and changing the diff tool back to kdiff3. It may have picked up an old kdiff3 installation.

If that doesn't work then giving me the output as described above will hopefully help us to figure out what's going wrong here.

Many thanks in advance.

0 votes
Deleted user Jul 30, 2013

Seems to work fine now, nothing has changed other than it's a new day, I haven't even restarted my Mac or done a sleep/wake.

I tried to mark this as answered already but for some reason it didn't take... Maybe this time...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,850 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you