It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree with two remotes does not push

I'm using SourceTree for mac version 2.7.6 (177)  and I'm having a hanging issue with bitbucket. Here's the scenario:

I have a project with 2 remotes, 1 repository on github and 1 bitbucket repository.
Normally, I pull from the github, develop on and push to bitbucket, but since 4th of July, returning from Holidays, my source tree hangs, in fact the pushing does not finish, it just "hangs" without a message.
I found a workaround, pushing from a command line like this:
git push --set-upstream
Once this command is done I can push again with only git push, but only via command line, via SourceTree still not working.


Thanks.
Ton Grommen

2 answers

0 votes
Manju Atlassian Team Jul 23, 2018

Can you enable "Always display full console output" in Preferences -> Advanced and paste the command that is executed by Sourcetree in your case here?

Output shown:

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push -v --tags origin refs/heads/MoreHue2-develop:refs/heads/MoreHue2-develop 

Pushing to ssh://git@origin.www.code.dtf.lighting.com:7999/mor/morehue2.0.git

 

And then nothing...................................................................

Do you get a pop-up for credentials? This might not show on first sight so be careful to monitor your screen

use ssh keys

so no credentials are needed

It could be that your default remote is the 'wrong' one, did you check? It might be that for the github remote you don't have access to push and for bitbucket you do (please check Settings->User and group access & Settings->Branch permissions).

I recently coincidentally had a similar problem took me an hour to figure out someone revoked my admin rights on the branch... waste of time... but at least setting it back solved my problem.

The problem occurs on a Mac, in the SourceTree on the Mac we cannot find the 

tools, options, authentication settings, any idea where they are on a Mac SourceTree?

I meant bitbucket settings, not sourcetree settings regarding the access rights.

 

As so far goes for remote, that you can verify in sourcetree. Just do $ git remotes than it will at least show the remotes you have for your repository. Right clicking the local branch and selecting push to remote gives you the option to push the either of the ones, it could be the default one is the github not bitbucket

$ git remote -v gives URLs by the way

Hue2.0  ssh://git@github.com/........git (fetch)

Hue2.0  ssh://git@github.com/.........git (push)

origin    ssh://git@origin.www.........git (fetch)

origin    ssh://git@origin.www........git (push)

So I have push for both github and bitbucket

no in your case only push origin

Why push to only one remote?

These are the permissions assigned to my account by the owner of repositories

Normally, I pull from the github, develop on and push to bitbucket

Manju Atlassian Team Jul 25, 2018

Hi @Ton Grommen Just curious, does this same thing work if you try on terminal?

Can you check if your ssh keys are loaded to the agent? You can run this in terminal to check, 

ssh-add -l

If the key isn't listed, you can add using below command

ssh-add <path_to_your_key>

The key was not listed but I added it using the command  ssh-add <path_to_your_key>  and it still does not work.

Manju Atlassian Team Aug 13, 2018

Are you sure the remote URL on your repo is ssh?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,942 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you