Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

SourceTree will not launch

rrbutler4 August 13, 2013

SourceTree indicated an update was available, after updating, it will not launch, I get 2 errors in the event log.

I have uninstalled and re-installed multiple times. I am the only user in my group affected.

Faulting application name: SourceTree.exe, version: 1.0.8.0, time stamp: 0x51f38a79
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b8479b
Exception code: 0xe0434352
Fault offset: 0x0000000000009e5d
Faulting process id: 0x1c7c
Faulting application start time: 0x01ce98724ca6800e
Faulting application path: C:\Program Files (x86)\Atlassian\SourceTree\SourceTree.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 9427d921-0465-11e3-97bd-040ccef0b0bf

Application: SourceTree.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Configuration.ConfigurationErrorsException
Stack:
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(System.String, Boolean, Boolean, Boolean, Boolean, System.Object ByRef, System.Object ByRef)
at System.Configuration.BaseConfigurationRecord.GetSection(System.String)
at System.Configuration.ConfigurationManager.GetSection(System.String)
at System.Configuration.ClientSettingsStore.ReadSettings(System.String, Boolean)
at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(System.Configuration.SettingsContext, System.Configuration.SettingsPropertyCollection)
at System.Configuration.SettingsBase.GetPropertiesFromProvider(System.Configuration.SettingsProvider)
at System.Configuration.SettingsBase.GetPropertyValueByName(System.String)
at System.Configuration.SettingsBase.get_Item(System.String)
at System.Configuration.ApplicationSettingsBase.GetPropertyValue(System.String)
at System.Configuration.ApplicationSettingsBase.get_Item(System.String)
at SourceTree.App..ctor()
at SourceTree.App.Main()

3 answers

1 accepted

0 votes
Answer accepted
rrbutler4 August 25, 2013

I performed a new install of windows 8 and reinstalled all apps. Sorry did not get to try your suggestion :)

5 votes
Pat Sissons September 23, 2013

tried removing just the tmpFFFF.tmp files, didn't work. Tried also removing all files in %TEMP% but that didn't work either.

Pat Sissons September 23, 2013

I was able to resolve this issue by removing the ...\AppData\Local\Atlassian\SourceTree.exe_Url_xxxxxxxxxx... folder (actually i just moved it). Upon further diagnosis, it appears that my user.config file in the 1.2.2.0 folder was full of NULL (\0) characters (about the same size as my previous version, 1.0.8.0, only slightly larger by a few bytes). I copied my old 1.0.8.0 user.config file over top of the 1.2.2.0 user.config file and sourcetree started up properly.

Like # people like this
bs-thomas May 14, 2016

Nice!!  Good call.  I've done all this Uninstall, Regedit clean, Repair, Reinstall MS .NET Framework 4, CCleaner, and all that you can imagine, and it didn't work.

Your one suggestion: Remove that damn folder "...\AppData\Local\Atlassian\SourceTree.exe_Url_xxxxxxxxxx" worked!!  Nice one Pat!

reyonlines
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 23, 2016

Really good call! this worked like a charm, thanks Pat

2 votes
Steve Chapman
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 19, 2013

I was getting the same error, not sure if it's the same underlying exception as you though. It seems SourceTree uses the Temp folder to store files, try the following and see if it fixes your problem:

  1. As you're running on Windows, open the Command Prompt and type %TEMP%
  2. Navigate to that folder and remove all the files (if you find lots of tmpFFFF.tmp files then this is almost definitely your issue)
  3. Once cleared try opening SourceTree again

Hope that helps

Elijah Cornell
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 1, 2015

Deleting the large amount of files 65K+ in my system's %TEMP% directory fixed this error for me.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events