It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree v3.0.6 minimize and maximize problem

Kristijan Gugec Oct 11, 2018

Hi,


I have recently updated SourceTree to 3.0.6 and detected some strange behaviour occurs while minimizing the app.


Application is always started normally but if I minimize the app window, it is not possible to get it back. Then I am forced to close the app from taskbar or Task Manager and start it again.


I'm currently running Windows 10 Enterprise. Colleagues who updated SourceTree to 3.0.6. are experiencing the same problem.

25 answers

1 accepted

0 votes
Answer accepted
Kristijan Gugec Nov 20, 2018

They fixed it a week ago in 3.0.9

SourceTree 3.0.9 [13 November 2018]

Changes

  • SRCTREE-6546 Support Email addresses as usernames for Bitbucket Server registration and accounts.
  • SRCTREE-6547 Fix being unable to re-open Sourcetree after minimizing
  • SRCTREE-6549 Fix Diff/Merge Tool configuration not being saved during restarts
  • SRCTREE-6568 Prevent showing git credential manager prompts if there's already one visible
  • SRCTREE-6571 Fix errors ith GitLab account creation and improve the labelling around Personal Access Tokens
Joel Santos Nov 20, 2018

Didn't work for me, I still have the same issue.

Jan Huebner Nov 20, 2018

Where do you get 3.0.9?

The official Download is still 3.0.8 and Source Tree itself is also not notify for an update.

Like # people like this
Tiago Rodrigues Nov 26, 2018

Just updated, still the same problem.

Arno van Oordt I'm New Here Dec 04, 2018

3.0.12 and still the same issue :(

Lu Ping Chen I'm New Here Dec 16, 2018

same here, got 3.0.12 and still got the issue

Like Charles Greer likes this
Rob Farthing Jan 02, 2019

Same here, seems like such a basic functionality issue too, what the hell is going on lately I use this software at work and these random usability issues just make it a pain

Charles Greer I'm New Here Jan 02, 2019

Yes.  I have the latest version, 3.1.12, hoping the issue would be fixed.  It is not.  I was going to propose this be our front end for GIT for my company, but with this issue I must seek other solutions...  On top of this it does not support versioning of a single file or blame.  Those are core features for a modern VCS.   Hope you get this issue fixed quick because I still like the front end...

Rob Farthing Jan 07, 2019

I'm going to see if I can add a new issue for this as it is not fixed in 3.0.12

Rob Farthing Jan 07, 2019

Have created a new issue for it here
3.0.12 issue post here<<

Jim Beale Jan 26, 2019

3.0.15 and still experiencing this issue.

Like # people like this
11 votes
John Lewin Oct 11, 2018 • edited

Also running into this same behavior on Version 3.0.6-beta-2193. Once SourceTree is minimized, clicking its taskbar button results in an audible Windows error ding and the application fails to be restored.

 An annoying workaround exists though. I can press Alt-Space (assuming the SourceTree taskbar button has focus) to bring up the system context menu and choose Restore. I was previously closing and reopening and this saves a few moments but is still tedious

Kristijan Gugec Oct 12, 2018

@John Lewin Wow, so it's not a bug, it's a feature :D

Sameer Ali Oct 29, 2018

Tools>Option>General>Repository settings> Refresh when application is not in focus

This does the trick.

Like # people like this
Gareth Blain Oct 30, 2018 • edited

Thanks that refresh in the background thing works! :)

federicop Oct 30, 2018

Good workaround @Sameer Ali, thanks!

Jan Huebner Nov 02, 2018

Thanks soo much Sameer!

That's really as saver for me as I ALWAYS minimize the Source Tree.

Makes me wonder how Atlassian could miss that?

Like Martijn Boeker likes this
Jose Vico Mar 26, 2019

Did the job. Thanks. It was being a real pain in the butt having to listen to that horrible Windows shitty bell

9 votes
Sameer Ali Oct 29, 2018 • edited

Solution 

Tools>Option>General>Repository settings> Refresh when application is not in focus.

The bug is related to the repository window not being refreshed in the background, This puts the application in a busy state by clicking the task-bar and prevents the window from refocusing in a timely manner. The above solution seems to be working.

ProMac Oct 29, 2018

Solved , Thks 

Matt Butler Oct 29, 2018

Works for me,  thanks @Sameer Ali!

Sameer Ali Oct 29, 2018

@Matt Butler Regrettably it is not a full proof solution, something is still a little odd while clicking the show desktop button ( minimize all open windows ) on the task bar. Which causes all open application windows to loose focus. If you click the source tree app icon immediately after this, you will receive the 'beep' sound the first time you click and only on the second attempt at clicking, will it then focus the source tree app. A work around for this is to click on another open app's task bar icon first and then proceed with clicking the source tree app icon. This way you can avoid the beep, which, TBQH, is really irking me. 

Max Beloborodko Oct 30, 2018

Thank you

Lu Ping Chen I'm New Here Dec 16, 2018

awesome works!

Bob Provencher Jan 14, 2019 • edited

Still happens with the option enabled and disabled on 3.0.12.

Rob Farthing Jan 15, 2019

Bob - I have created a new issue for it here as this one is apparently 'answered' and 'fixed' in 3.0.12... [3.0.12] Unable to restore Sourcetree once minimized on Windows 10

4 votes
Crusty Caesar Oct 11, 2018

Hi,

 

I have the same problem with SourceTree, I cannt Alt+Tab back into the SourceTree.

If i click on the icon in the Start Bar it makes some sound (maybe error sound?) If I am clicking fast the window will finaly pop up after a while.

Pls fix it.

Thx

Kristijan Gugec Oct 12, 2018

@Crusty Caesar I'm amazed by how you figured this out :)

Hope they will fix it soon.

Joel Santos Nov 13, 2018

In my case, I use a dock with my laptop, and when I undock it, some apps like to maximise to the now inexistent second screen. Alt + space helps to get them back to my laptop screen.

3 votes
Gordon Thompson Nov 22, 2018

A quicker way to restore it is to click on the icon in the taskbar and press Ctrl + Win + Up arrow

2 votes
Matt Butler Oct 26, 2018

Same here with SourceTree v3.0.8 on Windows 10 Home 1809 17763.55. 

Fast clicking also restores a stuck window, (after a lot of dinging sounds), so thanks to whoever figured that out!

One additional observation...

If I minimize by clicking the taskbar icon instead of the minimizer on the window then it restores without a problem.  I've tried with single monitor, dual monitor, with / without high DPI, taskbars in default / custom positions, all with the same result.

1 vote
David R. Cattley Oct 15, 2018

Same problem here.  Very annoying.

1 vote
Stéphane Perras Oct 25, 2018

Same here.  SourceTree 3.0.8 on Windows 10 version 1803 build 17134.345.

Clicking fast and alt-space restore work.  I get the bell sound when clicking the taskbar icon too.

Interresting thing I found:  When pressing Win+Tab, and then selecting the SourceTree window, will show the SourceTree window on the desktop for a fraction of a second but it will hide itself immediately with the bell sound.  Seems like something sets the window state back to hidden when it should not.

1 vote
federicop Oct 30, 2018

Workaround: Tools>Option>General>Repository settings> Refresh when application is not in focus

0 votes
Frederic Lacerte Oct 15, 2018

Same Here

0 votes
Joachim Michaelis Oct 16, 2018

Confirmed multiple times with SourceTree 3.0.6 in Windows 10 (build 1803, 64-bit).

0 votes
Ole Gunnar Borstad Oct 16, 2018

Confirmed. I dont think I will upgrade SourceTree ever again, they just bring too many regression bugs

0 votes
ProMac Oct 24, 2018

SourceTree 3.0.8.2279 + Windows 10 and same problem

I have this problem since the 3.0.6.

0 votes
Nicolas Clemeur Oct 24, 2018

Exact same problem here (started with 3.0.? and still in 3.0.8). Good to find here some workaround (clicking fast, or alt-space restore,), but still a really annoying bug

0 votes
Alex Grande Oct 24, 2018

Same problem here

0 votes
federicop Oct 25, 2018 • edited

Same problem with 3.0.5, 3.0.6 and 3.0.8 (windows 10 in all my pc)

I cannot win+tab, alt+tab, click taskbar icon, focus+click of the taskbar preview, focus from task manager.. nothing.

Sometime Sourcetree appears if i click quickly so many times the taskbar icon.

0 votes
Milos Davidovic Oct 26, 2018

Same here on Windows 8.1 Enterprise and Source Tree 3.0.6.

I hope this is fixed soon because it is very annoying.

0 votes
Giannis Koutsaftakis Oct 26, 2018

Same here with SourceTree v3.0.8 on Windows 10 Pro Version 10.0.17134 Build 17134.

0 votes
Jakub Holovsky Oct 29, 2018

Also having this problem with SourceTree v3.0.8 on Windows 10 Pro

0 votes
Sameer Ali Oct 29, 2018

Ditto,

Windows specifications

  • Edition      Windows 10 Pro
  • Version     1803
  • OS Build   17134.345

Sourcetree specifications

  • Version     3.08
0 votes
Gareth Blain Oct 30, 2018 • edited

Just to add some information to this bug you can't restore it using the menu that shows up when you right click on the preview (on the task bar icon). Although this menu looks the same as the one triggered by ALT+SPACE (which does work) it won't work as it throws the same error beep.

0 votes
Baris Erkus Nov 04, 2018

Same problem here.

3.08 annd Windows 10 64 bit 1809.

I occurs all the time. Cannot use the program. Have to close and re-open...

Baris Erkus Nov 04, 2018

After applying the workound, it behaves better. However, problem still persists...

0 votes
Joel Santos Nov 13, 2018

The "Refresh when not in focus" doesn't work for me. I click the icon and ALT + space / Restore to get it back. I'm on 3.0.8.2279 with Windows 10 with the latest October 18 update

0 votes
Tom Tanner Nov 14, 2018

I know me too is not really good form, but atlassian - this is atrocious behaviour

0 votes
Dániel Resperger Nov 23, 2018

Still not fixed:

Windows 7

ST: 3.0.10-beta-2469.exe

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,955 views 14 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you